cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

1) Does the recovery procedure mean the original application is installed or just that it is put in a state to accept new firmware?

I have done the recovery procedure on two sensors because I was having trouble downloading firmware in general and after the IDE claimed success, neither appear to start up via the battery or do anything at all (no LED activity, do not appear in the iOS test app anymore)

2) What is the magic sauce  in pushing the reset button to download firmware?

Even though I know I have the UART correct because the recovery claims to succeed, I can not get anything to download.  It always says to press restart.  I have the board removed and connected via the USB cable, same as for recovery.  I have pressed it, held it, done the combination with the boot button like for recovery, done other combinations with the boot button, held while inserting the usb cable and pretty much every variation I can think of without success using

WICED_SENSE-BCM920737TAG_Q32 download UART=COM7

or similar for other examples I have tried.

0 Likes
Reply
1 Solution
Anonymous
Not applicable

Hello boont

Yes to all.  At first I thought something was wrong with my setup in general as you suggest above, but I can download and have work any app in the sdk that I tried except wiced_sense to the sense

I stuck with tones and the glucose demo because it was easy to tell via sound or adv on iOS that the app was running, but a couple others I tried were fine too.

I started going back and forth trying to figure what was wrong with wiced_sense on mine, using tones or glucose as a control group that the basic infrastructure (download and run) were still working but never got the out of the box app to run.

Starting from scratch with a new app and bringing the functionality piece by piece worked.  Maybe i modified the original and didn't realize it, but everything i brought over to the new app to make it work I brought over unchanged so I don't think I modifield the original.

if I have time I may re-download the sdk and try on a different vm out of curiosity.   Buts it's fine, I'm running a customized version of the sense firmware now with a customized ios app which is what I wanted.

View solution in original post

0 Likes
Reply
7 Replies