cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

Hi Sir ,

I have six 20737s devices and use 2.2.1 sdk.

I look  "hello_client" project , it define a variable

#define HELLO_CLIENT_MAX_SLAVES4

and look "puart_control" project , it define a variable

#define PUART_CONTROL_MAX_CONNECTIONS8

I use puart_control project do actual test , Max can connections only four ,

When I try to connect a fifth device , the debug port display "connection failure" ,

Really can support connections to eight devices?

thanks you !

1 Solution
ArvindS_76
Employee

puart_control is probably missing a call to set the max number of slaves to 8. Try adding:

blecm_setmaxconnection(PUART_CONTROL_MAX_CONNECTIONS);

to APPLICATION_INIT()

View solution in original post

13 Replies
Anonymous
Not applicable

I think you need to change HELLO_CLIENT_MAX_SLAVES

0 Likes
Anonymous
Not applicable

Hi kwang

I use puart_control project


PUART_CONTROL_MAX_CONNECTIONS  8


but it only can connect four devices




0 Likes
Anonymous
Not applicable

Sorry I misread your post,

Are you using the WICED Sense kits? or your own custom board?

0 Likes
Anonymous
Not applicable
Hi  kwang


I buy bcm2073X kit * 3 from Broadcom,


and buy custom board(20737 chip) * 3 from Our country's company.


They have a difference?


or you suggest all device , need use bmc2073x kit ?


0 Likes
BoonT_56
Employee

Do all your evaluations on the tag3 board. The max number of slaves can be set up to 7. If you include the master, then it will be a total of 8 members in the piconet.

0 Likes
Anonymous
Not applicable

Hi boont

But I do actual test , a master can only connection four slaves ,limit.


Have you actually measured ?



hello_client project some code in "connection_up" event method :


    if (con_index >= HELLO_CLIENT_MAX_SLAVES)  // con_index = (0x40 ~ 0x43) - (0x40) , can connect four devices

    {

          ....

         return;

    }

puart_control project some code in "connection_up" event method ::


    if (con_index > PUART_CONTROL_MAX_CONNECTIONS) // The same situation as above

    {

        .....

        return;

    }

PUART_CONTROL_MAX_CONNECTIONS is 8 , but actual test only connected four devices (0x40~0x43).

Connect handle no more than 0x43 , because when I try connect fifth slave device , the first debuger port print "connection failure" .

After connected four devices, used bleprofile_Discoverable() method can't  Advertising.


0 Likes
MichaelF_56
Moderator
Moderator

Note that we confirmed today with the Developers that the 20737/36 will support up to 8 slaves (i.e. it will be the master of all the 8 slaves).

0 Likes
Anonymous
Not applicable

have anyone try use puart_control App connect more than four slave devices ?

0 Likes
Anonymous
Not applicable

Hi  kwang,boont

Maybe I description is not clear enough.

I step by step do to you look :

step 1:

Scan result  of five 20737 chip device:

scan resule.jpg

scan resule2.jpg

step 2:

Connect  address :0x1234567890DD

scan resule3.jpg

step 3:


Connect  address :0x1234567890CC


scan resule4.jpg


Step 4 :


Connect  address :0x1234567890AA


scan resule6.jpg


Step 5 :


Connect  address :0x1234567890EE


scan resule5.jpg


Step 6:

I finish connect four slave devices ,I try connect 5th device 0x1234567890BB slave devices,

but can't  connect it , no any connect success message !


scan resule7.jpg



step 7 :


final I click start advertisements , I use ble sinffer , not catch any package about this device.

and slave device 0x1234567890BB still advertisements !


scan resule9.jpg


-------------------------------------------------------------------------------------------------------------------------------------------------


Really can connect more than four slave devices ?





0 Likes
ArvindS_76
Employee

puart_control is probably missing a call to set the max number of slaves to 8. Try adding:

blecm_setmaxconnection(PUART_CONTROL_MAX_CONNECTIONS);

to APPLICATION_INIT()

View solution in original post

Anonymous
Not applicable

Hi thanks you ,

I add this function blecm_setmaxconnection(PUART_CONTROL_MAX_CONNECTIONS);

it slove my problem !

Anonymous
Not applicable

yaocing_shih is this still an issue?

0 Likes
Anonymous
Not applicable

Hi kwang !

Sorry Answer delay !

I No problem now.

Thank you for your interest