cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

Has anyone got this working yet and gave give me some pointers. I get the windows can not load the VM error message.

Many thanks, in advance.

1 Solution
MichaelF_56
Moderator
Moderator

tried this at home on my kids computer (64b/Windows 10) because we only have Windows 7 machines at work.

I first went in and updated the Java VM to version 8 64b.  This process also removed previous versions of the VM (versions 6 and 7).

Armed with the latest 64b Java VM, I then downloaded the .exe SDK installer from the community to my desktop, then double-clicked to begin the install process (vs. running it inside the browser).

Almost immediately, the following message popped up:

error-code.png

This is related to the LaunchAnywhere software used to create the installer, so I looked around online and found this: http://stackoverflow.com/questions/10920889/windows-error-2-occured-while-loading-the-java-vm

Since the Java site detects your browser automatically, downloading the 32b JVM is tricky, so I used the following link to download JVM 6/32b: http://stackoverflow.com/questions/5272216/is-it-possible-to-install-both-32bit-and-64bit-java-on-wi... and confirm that both 32b and 64b can reside on the same machine.

I was then able to get passed the InstallAnywhere error noted above.

However, I then came across the following error:

error-code2.png

After some research and reading the thread here on Microsoft's site: Installer User Interface mode Not Supported. - Microsoft Community

I recalled all of the Dell specific apps I needed to update to compatibility mode when I installed Windows 10 on this computer, so I gave that a try:error-code3.png

Elated and convinced I finally figured this out, I gave the .exe another try.

No luck.  The "The installer cannot run in this UI mode.  To specify the interface mode, use the I-command-line option, followed by the UI mode identifier.  The valid UI modes identifiers are GUI, Console, and Silent." error still appears.

I am convinced at this point that modifications need to be made by abisheka to the Windows installer we provide via the InstallAnywhere program used before this process will work.

Note that we also provide a .7z (WICED-Smart-SDK-2.2.1 (.7z Archive)) package that contains the raw files used by the installer, but I am only familiar at this point how to use those files to update an existing IDE/installation, not create a new one.

Perhaps someone with more experience using the Eclipse IDE can comment.

I know the download is available here: Eclipse Downloads

Once installed, jaeyoung's blog here: How to Import a New SDK into an Existing WICED Smart IDE could be used.

seyhan vik86 abuch

View solution in original post

9 Replies
MichaelF_56
Moderator
Moderator

tried this at home on my kids computer (64b/Windows 10) because we only have Windows 7 machines at work.

I first went in and updated the Java VM to version 8 64b.  This process also removed previous versions of the VM (versions 6 and 7).

Armed with the latest 64b Java VM, I then downloaded the .exe SDK installer from the community to my desktop, then double-clicked to begin the install process (vs. running it inside the browser).

Almost immediately, the following message popped up:

error-code.png

This is related to the LaunchAnywhere software used to create the installer, so I looked around online and found this: http://stackoverflow.com/questions/10920889/windows-error-2-occured-while-loading-the-java-vm

Since the Java site detects your browser automatically, downloading the 32b JVM is tricky, so I used the following link to download JVM 6/32b: http://stackoverflow.com/questions/5272216/is-it-possible-to-install-both-32bit-and-64bit-java-on-wi... and confirm that both 32b and 64b can reside on the same machine.

I was then able to get passed the InstallAnywhere error noted above.

However, I then came across the following error:

error-code2.png

After some research and reading the thread here on Microsoft's site: Installer User Interface mode Not Supported. - Microsoft Community

I recalled all of the Dell specific apps I needed to update to compatibility mode when I installed Windows 10 on this computer, so I gave that a try:error-code3.png

Elated and convinced I finally figured this out, I gave the .exe another try.

No luck.  The "The installer cannot run in this UI mode.  To specify the interface mode, use the I-command-line option, followed by the UI mode identifier.  The valid UI modes identifiers are GUI, Console, and Silent." error still appears.

I am convinced at this point that modifications need to be made by abisheka to the Windows installer we provide via the InstallAnywhere program used before this process will work.

Note that we also provide a .7z (WICED-Smart-SDK-2.2.1 (.7z Archive)) package that contains the raw files used by the installer, but I am only familiar at this point how to use those files to update an existing IDE/installation, not create a new one.

Perhaps someone with more experience using the Eclipse IDE can comment.

I know the download is available here: Eclipse Downloads

Once installed, jaeyoung's blog here: How to Import a New SDK into an Existing WICED Smart IDE could be used.

seyhan vik86 abuch

View solution in original post

Anonymous
Not applicable

It is good to get clarity and it is obvious you did a lot of work to validate that is can not work on Win10.

Thanks kindly for your effort.

Is there any chance your software team will address this any time soon.

All of our machines are updated. Microsoft is really pushing Win10, and it is much better than Win8.1.

Joe

0 Likes
Anonymous
Not applicable

I had the same problem - found that WICED Version 1 works on Win 10, so I'm working with that for now. I tried to update to 2.2.1 using the .7z file, not sure if it worked yet.

0 Likes
MichaelF_56
Moderator
Moderator

eferber

Note that SDK 1.1 ONLY supports the older 20732S and the associated TAG2 board.

It will not work with the newer devices and tools.

0 Likes
Anonymous
Not applicable

Can you upgrade from SDK 1.1 to SDK 2.2.1 using the .7z file? I followed the instructions in the blog and it doesn't work.

0 Likes
Anonymous
Not applicable

joe@openbikeinc

I found a solution that worked perfectly:

1. Remove all existing Java installations - by using control panel/uninstall programs

2. Go to Java Archive Downloads - Java SE 8 and download Java Runtime Environment version 8.20 for Windows x86 (32-bit).

3. Run the WICED SDK 2.2.1 Installer.

Elad

MichaelF_56
Moderator
Moderator

Excellent!  Thanks for figuring this out Elad.

0 Likes
Anonymous
Not applicable

I have other programs that depend on the older versions of Java, so what should I do?

0 Likes
Anonymous
Not applicable

Elad's solution worked for me - it was the only proposed solution that actually worked, the others not so much.

Elad = hero!!

0 Likes