cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Anonymous
Not applicable

Hi,

    I'm using MAX2084 Evaluation kit, in that kit  cyusb2014-bzx driver IC present when power on the board as per the EVM kit instruction. the system not detect. our system windows 7 professional 64 bit.

0 Likes
Reply
1 Solution
Employee

Hi Chandran,

You don't need to complie the source code. Download the driver files Drivers for EZ-USB® FX1™ , FX2LP™ , and FX3™ - KBA94413

and follow the document attached.

However, the host should be able to find something even if you don't have driver files. In normal case, something should appear in device manager. Device manager could not find the corrpesonding driver and will report it as an unknown device.

You said that nothing appears in device manager. This is not what we expect. Could you please check

1. if the crystal outputs clock and the amplitude?

2. if all the necessary power domains works well, 1.2V/1.8V/3.3V, etc.

In addition, please try to replace the USB cable/the PC/the USB port to check if anyhing is broken.

View solution in original post

0 Likes
Reply
13 Replies
Employee

Hi Chandra,

Could you please upload the schematic file of this EVK?

0 Likes
Reply
Anonymous
Not applicable

Hi,

Hereby attached MAX2084 EVM kit schematic file.

Best Regards,

B.Chandran

0 Likes
Reply
Employee

Hi chandran,

Please set the PMODE to USB boot. Connect FX3 to PC via USB cable. If no device, please

1. check if the crystal outputs clock

2. check if all the necessary power domains works well.

0 Likes
Reply
Employee

I suspect that the first step in the instruction guideline is to enumerate FX3 as USB bootloader device, is that right?

After that, you could download firmware through USB port.

0 Likes
Reply
Anonymous
Not applicable

yes. As per the datasheet Cypress FX3 Boot Options (J144), sourced from

FX3 datasheet

PMODE(2:0) J144 Position Boot From MAX2084

F11* 1-2, 3-4 USB boot* Yes

i have done that.

They are given in the datasheet "If this is the first use of the MAX2084 EV

Kit on the connected PC, then the Cypress USB 3.0 kernel mode driver must

be installed. Can you tell me about that.

0 Likes
Reply
Employee

Hi Chandran,

When you connect FX3 to host from USB(usb bootloader), FX3 will need driver to enumerate as a vendor device. In this mode, you are able to download firmware into FX3 RAM or EEPROM/FLASH.

If you download firmware into RAM, the FX3 will auto re-enumerate with this firmware(don't need to change PMODE).

If you download firmware into EEPROM/FLASH. then you need change PMODE to I2C boot or SPI boot, and reset the board, FX3 will enumerate again with this firmware.

If you have not installed driver for FX3, your PC should also find a new device in the device manager.

Please clarify your case,

1. Is the host not finding anything

2. Or the host find a new device attached but doesn' have the corresponding driver?

0 Likes
Reply
Anonymous
Not applicable

Hi,

Good morning. The host not finding anything. In the datasheet "If this

is the first use of the MAX2084 EV Kit on the connected PC, then the

Cypress USB 3.0 kernel mode driver must be installed". I have downloaded

the cypress USB suite source but it required visual studio 2015 visual

studio need internet explorer 10. Internet Explorer will not install in our

system Windows 7 Professional.

guide me step by step to download and install driver software.

Regards,

B.Chandran

0 Likes
Reply
Employee

Hi Chandran,

You don't need to complie the source code. Download the driver files Drivers for EZ-USB® FX1™ , FX2LP™ , and FX3™ - KBA94413

and follow the document attached.

However, the host should be able to find something even if you don't have driver files. In normal case, something should appear in device manager. Device manager could not find the corrpesonding driver and will report it as an unknown device.

You said that nothing appears in device manager. This is not what we expect. Could you please check

1. if the crystal outputs clock and the amplitude?

2. if all the necessary power domains works well, 1.2V/1.8V/3.3V, etc.

In addition, please try to replace the USB cable/the PC/the USB port to check if anyhing is broken.

View solution in original post

0 Likes
Reply
Employee

Have you solved this problem?

0 Likes
Reply
Anonymous
Not applicable

Yes. The problem solved. Thanks for your support.

0 Likes
Reply
Employee

What's the root cause of this problem?

0 Likes
Reply
Anonymous
Not applicable

Exact voltage not provided to the cypress Ic. Jumper setting mistakes in

MAX EV kit datasheet.

0 Likes
Reply
Employee

Get it. I will close this thread later.

0 Likes
Reply