cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

New Contributor II

Hi

According to the Steps to Setup up MIPI CSI Camera Solution with CX3 – KBA225748 in step 9 after I have saved all the generated files 1 by 1 the cyu3imgasensor.c should also be automatically generated, however this does not happen in my project.

As you can see in the image below after I have saved all the configuration files I do not see this file in my project directoryScreenshot from 2020-09-14 14-14-03.png

I can see the cyu3imgasensor.h in my includes in the path fw_lib/1_3_4/inc but not the c file. That said I can still build and flash the example code without problem I am just wondering where this file is.

NOTE: I am using the Denebola RDK and the OV5640 example that comes with the FX3 SDK (Cx3UvcOV5640) and not the example code that comes with the RDK from e-con(CX3RDK-OV5640) Can you also let me know what is the difference between these two example codes?

Best Regards

Ali

0 Likes
Reply
1 Solution
Moderator
Moderator

Hello Ali,

From the snippet that you have shared, it seems that you are using the "Predefined Configuration" in the CX3 configuration tool instead of the "Configuration with Basic settings"

To get the cyu3imgasensor.h and cyu3imgasensor.c file "Configuration with Basic settings" needs to be checked. As shown in the snippet attached.

I have also attached the project generated after checking the "Configuration with Basic Settings"

I am using the Denebola RDK and the OV5640 example that comes with the FX3 SDK (Cx3UvcOV5640) and not the example code that comes with the RDK from e-con(CX3RDK-OV5640) Can you also let me know what is the difference between these two example codes?

>> Please share the CX3RDK - OV5640 firmware that you are referring

Regards,

Rashi

Regards,
Rashi

View solution in original post

0 Likes
Reply
5 Replies
Moderator
Moderator

Hello Ali,

From the snippet that you have shared, it seems that you are using the "Predefined Configuration" in the CX3 configuration tool instead of the "Configuration with Basic settings"

To get the cyu3imgasensor.h and cyu3imgasensor.c file "Configuration with Basic settings" needs to be checked. As shown in the snippet attached.

I have also attached the project generated after checking the "Configuration with Basic Settings"

I am using the Denebola RDK and the OV5640 example that comes with the FX3 SDK (Cx3UvcOV5640) and not the example code that comes with the RDK from e-con(CX3RDK-OV5640) Can you also let me know what is the difference between these two example codes?

>> Please share the CX3RDK - OV5640 firmware that you are referring

Regards,

Rashi

Regards,
Rashi

View solution in original post

0 Likes
Reply
New Contributor II

Hi Rashi,

Thanks for the answer that makes sense.

Regarding the projects I am referring to:

The Cx3UvcOV5640 found in FX3 SDK firmware example with the following path: /FX3_SDK_1.3.4_Linux/fx3_firmware_linux/cyfx3sdk/firmware/cx3_examples/cycx3_uvc_ov5640

And

The CX3RDK-OV5640 downloaded from E-consystems Denebola (See3CAM_CX3RDK) - Technical Documents​ and found under the following path: DENBOLA-RDK/e-con_CX3RDK_OV5640_Firmware_Package/SDK_1.3.3/See3CAM_CX3RDK_ e-CAM59CX3/CX3RDKOV5640

  • From my understanding they are both sample example code for the Denebola RDK I can also build and flash both on to the RDK using the EzUSBSuite on Windows. However I am unable to do this on Linux.
    On Linux I can only build the project that comes with the FX3 (Cx3UvcOV5640). The E-con project (CX3RDK-OV5640) has a different build configuration and I suspect E-con has built this project on windows hence having CS-make and it is not working on Linux see images below for the build configs I am referring to:
    Cx3UvcOV5640.png
    CX3RDK_OV5640_Build config.png
    Do you have a build configuration for the CX3RDK-OV5640 project that works on Linux?
    I did play around with this for a while but was unable to get it to build on Linux I get the following error when I sent the builder type to External builder cs-make :
    cs-make.png
    This is expected as cs-make is for windows and not Linux but when I set this from external builder to internal builder then I get the following error while building the CX3RDK-OV5640 project.
    lib.png
    I think has to do with linking the libraries which I also attempted to fix by linking the libraries just like how it is linked in the sample project from fx3 (Cx3UvcOV5640) but it still did not build so any advice here?

  • The CX3RDK-OV5640 project has UVC implementations for brightness saturation etc where as the Cx3UvcOV5640 lacks these features in the Firmware. Is this correct?

Thanks in advance for taking the time to answer this question

Cheers

Ali

0 Likes
Reply
Moderator
Moderator

Hello Ali,

Do you have a build configuration for the CX3RDK-OV5640 project that works on Linux?

>> Can you try programming the FX3 with the built image file. Is that working?

It seems that the problem is in the project settings. Please check if the build settings and other project settings are the same for both the firmware. Try setting the library paths manually instead of using the environment variable.

Please refer to this thread with a similar error Compiling examples in Linux with Cypress EZ USB Suit.

The CX3RDK-OV5640 project has UVC implementations for brightness saturation etc whereas the Cx3UvcOV5640 lacks these features in the Firmware. Is this correct?

>> The Cx3UvcOV5640 does not currently implement any UVC functions (Brightness, Contrast, Exposure, etc.). This example has autofocus enabled.

Please let me know if any queries

Regards,

Rashi

Regards,
Rashi
0 Likes
Reply
New Contributor II

Hi Rashi,

Yes the example from the FX3 works both in windows and linux my issue is with the e-con systems example which also compiled in windows but not in Linux. Regarding comparing the 2 build configurations I did exactly that however, I could not manage to compile the e-con example.

I tried the steps in Compiling examples in Linux with Cypress EZ USB Suit. I still get the following error
lib.png

>>Try setting the library paths manually instead of using the environment variable

Can you please let me know how I should do this and what libraries are needed so I can link them manually?

I have also attached all the build configuration of the e-con systems project for your reference:

build var.pngbuild step.png
linker.pnglibCX3.png

Cheers

Ali

0 Likes
Reply
Moderator
Moderator

Hi Ali,

For the error snippet that you have shared in the post, please confirm if the below-mentioned path is included in the project settings > C/C++ Build > Settings> Tool Settings Tab > GCC C compiler & GCC Assembler > include or directories

FX3 SDK installation path \FX3_SDK_Linux\fx3_firmware_linux\cyfx3sdk\fw_lib\1_3_4 (SDK version used)\inc

After adding the path try to refresh the project and rebuild.

Regards,

Rashi

Regards,
Rashi
0 Likes
Reply