cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Anonymous
Not applicable

USB Control Center gets this error..."Cypress Boot Programmer Device Not Found" 

   

The board enumerates as WestBridge 0x04B4 0x00F3.

0 Likes
Reply
9 Replies
Anonymous
Not applicable

Hi,

   

On clicking which button does this error show up?

   

Regards,

   

Anand

0 Likes
Reply
Anonymous
Not applicable

I'm using the FX3 EEPROM on the Program pull down menu.

0 Likes
Reply
New Contributor II

I have the same problem "Cypress Boot Programmer Device Not Found" when write to FX3 EEprom,  any solution?

0 Likes
Reply
Moderator
Moderator

Hello,

Please create a post with your query in Cypress Developer Community’s USB SuperSpeed Peripheral’s section - Link.

Your query will be answered by a product expert.

Regards,
Yashwant

0 Likes
Reply
New Contributor

I have the same problem here. I have a CX3 chip set to boot from SPI flash with fallback to USB. I've also tried setting the PMODE links to USB boot only, but it doesn't change anytthing.

The symptoms are: I connect the USB cable, and see "Cypress FX3 USB BootLoader Device" in Control Center. I select it and press Program -> FX3 -> SPI FLASH. The device disappears from the list and there is a message, "Waiting for Cypress Boot Programmer device to enumerate..." at the bottom of the window. After a few seconds, that changes to "Cypress Boot Programmer Device Not Found".

I don't understand how the Bootloader device can work but the boot programmer one never appears.

I'm using Windows 10, 64-bit.

Thank you

Chris

0 Likes
Reply
New Contributor II

I designed a board has the same schematic as CYUSB3KIT-003.

When I connect the board to my PC and opened Control center, it shows:  Cypress FX3 USB BootLoader Devices.

all the information for the board is exactly the same as which of CYUSB3KIT-003.

When I program the board to RAM, it shows: Programming succeeded, but the computer alerts:  USB device can't recognize

I deconnected the board and connected again, try to program to EEPROM, it first shows: "waiting for Cypress Boot Programmer Device to enumerate", and then "Cypress Boot Programmer Device Not Found"

I'm sure the Pmod[2:0] set as:  "F11" and  the the "CyBootProgrammer.img" file is at

C:\Cypress\EZ-USB FX3 SDK\1.3\application\c_sharp\controlcenter

I tried to program  "CyBootProgrammer.img" to the RAM directly, It succeeded, and shows:  "Cypress  FX3 USB BootProgrammer Device" in the control center window

When I tried program CYUSB3KIT-003 board following the same procedure as above, it works successfully.

I searched community froum, there are some similar question, but no answer for mine.

0 Likes
Reply
New Contributor

I've just tried explicitly programming CyBootProgrammer.img in to my board too, and it programs in to RAM successfully but I don't see the BootProgrammer device in the control center. Odd.

0 Likes
Reply
New Contributor II

Hi, you may need to change a PC to try,  although totally failed in my 5 year old HP laptop, 2 out of 10 was succeed in a new HP laptop. you can go to my original post to see my work.FX3 Boot Programmer Device Not Found

0 Likes
Reply
New Contributor

I've just tried the same test but under Linux, having built the cyusb_linux tool, and I get exactly the same result: programming an image (any image) into RAM works, but then the USB device just disappears. lsusb shows nothing at all. I'll be able to try it on another CX3 board soon.

0 Likes
Reply