cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Anonymous
Not applicable

 hi everyone

   

I meet aproblem .I have a usb 3.0 board, when it connect with usb2.0 port ,the PC device mananer Recognition as usb2.0 device,when connect with usb3.0 port the PC mananger Recognition as usb 3.0 device .but  the device will be detach secends soon and attach after  secends .USB2.0 is stable。what can be lead this problem .who can help me. 

   

test SDK 1.2 /1.1/1.1.2

   

test OS :win 7 64bit /win7 32 bit

   

It maybe hardware problem.(board is make by myself) Any notices with board

   

thanks

0 Likes
Reply
5 Replies
Anonymous
Not applicable

 By the way  ,the board CLK is 26MHz .It is 19.2MHz with previous and it is work well。

0 Likes
Reply
Anonymous
Not applicable

 Hi,

   

What are the differences between old and new boards?

   

Could you please double check your power domain connections and decoupling capacitors?

   

Regards

   

Prajith

0 Likes
Reply
Anonymous
Not applicable

 hi PRJI 

   

Thanks for your replay.

   

I am a software engineer, My hardware Engineer tell me that the differences are  the CLK(previous 19.2MHz now 26MHz) and High voltage(previous 1.8v now 3.3v). when 3.0port connected the device attach - detach - attach -detch........ .But 2.0port connected it is stable. 

   

When the CLK change to 26MHz ,does the formware need to do something ?(e.g:the CPU clk Frequency-divisional) If it is need please tell me .thanks ! 

   

By the way what the mean of "domain connections" and how to check.

0 Likes
Reply
New Contributor

 Are you sure the 3.0 descriptors are correct, please check once using uvc view, this happened to me before , but i think i had given wrong length values in the descriptors.

   

Rags

0 Likes
Reply
Anonymous
Not applicable

 Hi RAJS 

   

Thanks for your infoemation .I have test with the uvc example ,and it is really stable with usb 3.0 port .

   

But the uvc is a apecific device.the base class is 0xFE ,I want to use 0xFF (as a Vendor specific device ). 

   

I checked my descriptor ,and is correct. Why it is stable as a uvc device.and others are unstable? Can you eaplain for me Thanks!

   

 

   

best regard!

0 Likes
Reply