cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

New Contributor II

My project is a CX3 application under git revision control using a segger debugger. The goal is to make the commited fiels as muchpath-independent as possible.

The cypress and gnu tools depends on instalaltion path so there is no simple way for them

But, when launching the debugger I get this strange error as soona s I set tro break points

No source file named C:UsersMarco StanzaniDocumentsBlue Thinkmipi_2_usbFWmipi2uvccycx3_uvc.c.

No source file named C:UsersMarco StanzaniDocumentsBlue Thinkmipi_2_usbFWmipi2uvccycx3_uvc.c.

it look like something is pruning the slashes in the path, fooling the gdb ...

whre these paths are stored in the eclipse files? I cannot find this so far

Thanks

0 Likes
Reply
1 Solution
Moderator
Moderator

Hello,

In the source tab, please try adding Path relative to source folders by selecting add option and let me know the result.

Best Regards,

Jayakrishna

Best Regards,
Jayakrishna

View solution in original post

14 Replies
Moderator
Moderator

Hello,

Please let me know whether you are receiving this error after setting just a single break point or multiple break points.

Best Regards,

Jayakrishna

Best Regards,
Jayakrishna
0 Likes
Reply
New Contributor II

Single

Il mer 18 dic 2019, 07:51 JayakrishnaT_76 <community-manager@cypress.com>

ha scritto:

<http://www.cypress.com>

Cypress Developer Community

<https://community.cypress.com/?et=watches.email.thread>

Strange behaviour when setting breakpoints (slashes pruning from

pathnames)

reply from JayakrishnaT_76

<https://community.cypress.com/people/JayakrishnaT_76?et=watches.email.thread>

in USB Superspeed Peripherals - View the full discussion

<https://community.cypress.com/message/218912?et=watches.email.thread#218912>

0 Likes
Reply
Moderator
Moderator

Hello,

Thanks for the reply. Please let me know by path whether you are referring to the installation path used by gnu tools or not?

Best Regards,

Jayakrishna

Best Regards,
Jayakrishna
0 Likes
Reply
New Contributor II

The Path refers to a c source file

Il mer 18 dic 2019, 08:09 JayakrishnaT_76 <community-manager@cypress.com>

ha scritto:

<http://www.cypress.com>

Cypress Developer Community

<https://community.cypress.com/?et=watches.email.thread>

Strange behaviour when setting breakpoints (slashes pruning from

pathnames)

reply from JayakrishnaT_76

<https://community.cypress.com/people/JayakrishnaT_76?et=watches.email.thread>

in USB Superspeed Peripherals - View the full discussion

<https://community.cypress.com/message/218919?et=watches.email.thread#218919>

0 Likes
Reply
New Contributor II

The correct path should have been

C:/Users/Marco Stanzani/Documents/Blue Think/mipi_2_usb/FW/mipi2uvc/cycx3_uvc.c

This is the main program file of the MIPI2UVC application as generated by EZUSB CX3 echosystem

0 Likes
Reply
New Contributor II

FYI This is not the  cycx3_uvc_ov5640 example project (I have been told not to use this in another question of this forum: how much should I rely to the AN90369 app note?)

0 Likes
Reply
Moderator
Moderator

Hello,

Can you share a screenshot of your debug configurations and the error.

Best Regards,

Jayakrishna

Best Regards,
Jayakrishna
Moderator
Moderator

Hello,

Can you please share the screenshot of source section of the debug configuration.

Best Regards,

Jayakrishna

Best Regards,
Jayakrishna
New Contributor II

FYI I was thinking 'Marco Stanzani' as a windows 10 user - i.e. a string with blank spaces - may create issues to programs which do not trim correctly spaces from strings - handly badly escape charaters - so desperately I create a new user without blank spaces. No joy, same issue

For your information all of this works correctly on the same PC, same windows installation, with another user

0 Likes
Reply
Moderator
Moderator

Hello,

In the source tab, please try adding Path relative to source folders by selecting add option and let me know the result.

Best Regards,

Jayakrishna

Best Regards,
Jayakrishna

View solution in original post

New Contributor II

Hello javakrishna

it works now!

First: thank you very much ... I was getting really frustrated about this issue. This still does not explain why the same project move among different PCs (when I say moved I mean copy eclipse workspaces to/from PCs) sometimes works and sometimes not ...

Secondly: I think the EZUSB distribution must be changed bt Cypress to include this option during installation. I do not understand under which circumstances this issue pops ups, though I like this oprtion from a SW engineering standpoint (working with relative paths make the projects robust and portable

I do not know if you are a cypress application or not: anyway I hope somebody escalate to the cypress people and consider tis

Finally: thanks much again. You made my weekend much better

0 Likes
Reply
Moderator
Moderator

Dear Marco Stanzani,

We have forwarded your query to our product development team, who will evaluate your query.

Thank you for your interest in Cypress products

Best Regards

Jayakrishna

Best Regards,
Jayakrishna
0 Likes
Reply