cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

user_4352311
New Contributor

Hello,

I using a FX3 SuperSpeed USB development kit along with a custom MT9M114 development board. The board MT9M114 has been tested and works fine with an OnSemi Demo3 board. The on-board oscillator has a frequency of 24MHz.

I'm programming the FX3 RAM with the application note AN75779 (How to Implement an Image Sensor Interface with EZ-USB FX3 in a USB Video Class UVC Framework) source code, compiled with EZ Suite USB. The source code remains unchanged.

A UVC device then appears but the results I get are strange (see screenshot below). White appears as magenta and black appears as green. However, from time to time the colors are good and appears as expected.

Where could be a good place to start ? I tried to compile the code with DEBUG_PRINT_FRAME_COUNT defined but this doesn't help much.

I remain at your disposal should you have any question.

Best regards.

Clément

0 Likes
1 Solution
user_4352311
New Contributor

Hello,

Thanks for your quick reply. It was apparently an impedance issue between the FX3 SuperSpeed USB development kit and the custom MT9M119 development board.

The colors are now correct.

Best regards

Clément

De : YashwantK_46 <community-manager@cypress.com>

Envoyé : mardi 23 juillet 2019 07:46

À : Clement Lestrelin <clement.lestrelin@groupe-leader.fr>

Objet : Re: - FX3 with AN75779 source code and MT9M114, color modification

<http://www.cypress.com>

Cypress Developer Community <https://community.cypress.com/?et=watches.email.thread>

FX3 with AN75779 source code and MT9M114, color modification

reply from YashwantK_46<https://community.cypress.com/people/YashwantK_46?et=watches.email.thread> in USB Superspeed Peripherals - View the full discussion<https://community.cypress.com/message/203445?et=watches.email.thread#203445>

View solution in original post

0 Likes
2 Replies
YashwantK_46
Moderator
Moderator

Hi,

We have tested FX3 with MT9M114 and didn't find any problems as such.

Can you please provide the FX3, GPIF and Camera Interface Schematics?

Also, if you have another sensor (MT9M114), can you please check with it?

Regards,

Yashwant

user_4352311
New Contributor

Hello,

Thanks for your quick reply. It was apparently an impedance issue between the FX3 SuperSpeed USB development kit and the custom MT9M119 development board.

The colors are now correct.

Best regards

Clément

De : YashwantK_46 <community-manager@cypress.com>

Envoyé : mardi 23 juillet 2019 07:46

À : Clement Lestrelin <clement.lestrelin@groupe-leader.fr>

Objet : Re: - FX3 with AN75779 source code and MT9M114, color modification

<http://www.cypress.com>

Cypress Developer Community <https://community.cypress.com/?et=watches.email.thread>

FX3 with AN75779 source code and MT9M114, color modification

reply from YashwantK_46<https://community.cypress.com/people/YashwantK_46?et=watches.email.thread> in USB Superspeed Peripherals - View the full discussion<https://community.cypress.com/message/203445?et=watches.email.thread#203445>

View solution in original post

0 Likes