cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

DaSm_1109836
New Contributor

I am developing a UWP Windows application that uses CyAPI.lib. However, when instantiating a new object with

   

m_pUSBDevice = new CCyUSBDevice(NULL, CYUSBDRV_GUID, true);

the call returns garbage in the m_pUSBDevice object except that it is returning a device count of 1 (as expected).

However, using this same call in a C++ console application, the object instantiation works just fine... I can view the object and determine that it indeed is seeing the FX3 connected device. Is there some issue with UWP that prevents the library from returning all of the device information properly? And can it be fixed or is there an upgrade to the library? Any help would be greatly appreciated.

Also, for the record, this app will not be going onto the Windows store, but used for the enterprise... UWP is being used because of its rich set of UI controls and the ability to tailor them.

0 Likes
Reply
1 Solution
Anonymous
Not applicable

Hi,

We haven't tested our libraries with UWP yet.

I will update you next week on if there is any future plan.

Regards,

-Madhu

View solution in original post

0 Likes
Reply
2 Replies
Anonymous
Not applicable

Hi,

We haven't tested our libraries with UWP yet.

I will update you next week on if there is any future plan.

Regards,

-Madhu

View solution in original post

0 Likes
Reply
DaSm_1109836
New Contributor

Thank You!!!!

0 Likes
Reply