cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Anonymous
Not applicable

Hi, 

   

I am learning USB development with Cypress FX3 and I met a problem when going through the tutorials. 

   

I got stuck at the step when I need to use "Project -> Build Project" to generate image file in EZ USB Suite. I got a lot of files, like  D file, O file, elf file, etc. except the image file. Does anyone meet the same problem before? Has anyone solved this problem? 

   

By the way, "cs-make[1]: [post-build] Error 2 (ignored)" is showed after I 'build' the project. I am running 64 Win10 OS.

   

Best,

   

Eric 

0 Likes
Reply
1 Solution
Moderator
Moderator

Yes, Please add the following command in Post-Build Steps in Eclipse Properties.

'${FX3_INSTALL_PATH}/util/elf2img/elf2img.exe' -i ${ProjName}.elf -o ${ProjName}.img -v

File->Properties->C/C++ Build ->Settings ->Build Steps ->Post-build steps

View solution in original post

0 Likes
Reply
7 Replies
Anonymous
Not applicable

1) Are you getting the same problem with all the firmware, or only one particular firmware is not building? 

   

2) Have you make sure that you selected "copy to workspace" while importing the project ? 

   

3) I suppose you are using Windows. Please go through the attached application note which shows how to import and build existing projects. Please refer section 8 of the AN75705  http://www.cypress.com/documentation/application-notes/an75705-getting-started-ez-usbr-fx3tm-zh

0 Likes
Reply
Anonymous
Not applicable

Hi, 

   

It seems the problem only happens when I try to generate image file for project AN75705. I tried some examples in the files and there is no problem. 

   

Best,

   

Eric

0 Likes
Reply
New Contributor II

I have the same problem with AN75779 example project. I edited the make file to add elf2img. But still, there is no image file generated. Can anyone help? Thanks

0 Likes
Reply
Moderator
Moderator

Please download the latest AN75779 App Note firmware.

We have fixed this issue and also added other features too.

Check App Note Revision History for added features.

New Contributor II

srdr,

Thanks. I downloaded the new ones and it is working now.

0 Likes
Reply
New Contributor II

Hi, the best thing is to add a final step to any makefiles you are using for your project(s), as shown below. In this case 'make' will expect the elf2img utility to be available. elf2img itself is generally found in the util/elf2img folder of the FX3 SDK. HTH.

   
compile: $(C_OBJECT) $(A_OBJECT) $(EXES)     # add the step necessary to create an img file     ../elf2img/elf2img -i $(MODULE).elf -o $(MODULE).img 
0 Likes
Reply
Moderator
Moderator

Yes, Please add the following command in Post-Build Steps in Eclipse Properties.

'${FX3_INSTALL_PATH}/util/elf2img/elf2img.exe' -i ${ProjName}.elf -o ${ProjName}.img -v

File->Properties->C/C++ Build ->Settings ->Build Steps ->Post-build steps

View solution in original post

0 Likes
Reply