cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Anonymous
Not applicable
        I tried to write 100kB boot img on 1Mb EEPROM(AT24C1024B-TH) by CyControl.exe but, it failed. Are there any mistake about my process? I show several matters as shown bellow. 1. 27kB boot img (Fx3BootAppGcc.img), it succeeded to write. 2. I changed compile mode from Debug to Release on creating USBBulkLoopAutoEnum.img because that file is 130kB on Debug mode. 3. I tried to write 100kB(USBBulkLoopAutoEnum.img) same way as 27kB (Fx3BootAppGcc.img), but it failed after about 10 seconds waiting. I think size of EEPROM is enough to be written, because AT24C1024B-TH is 1Mb(128kB) and I tried to write 100kB file. Additional info is here. a. A0 pin of AT24C1024B-TH is NC b. A1 and A2 pin of AT24C1024B-TH is Pull-down with 3.3k ohm. If someone has experience to write AT24C1024B-TH on FX3 board, please advise me...   
0 Likes
1 Reply
Anonymous
Not applicable

Try the following thing:

   

Copy the .elf file to the folder where elf2img.exe is present.

   

Open a command prompt (Start --> Run --> cmd). Go to the elf2img folder (in my case: C:\Cypress\FX3 SDK\util\elf2img) in the command prompt. Then give the following command:

   

elf2img.exe -i USBBulkLoopAutoEnum.elf -o USBBulkLoopAutoEnum.img 0x0C 0xB0 -vectorload yes

   

Here I am assuming the name of the .elf file as USBBulkLoopAutoEnum.elf. In your case it might be a different one.

   

After running the above mentioned command it will output a .img file. Use that .img file to program the EEPROM.

   

Thanks,

   

sai kirshna.

0 Likes