cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

VlKh_2251656
Contributor II

Hello

I have an PC  with mainboarf P5P43TD and win7 64bit (professional)

I check ports USB3 on this PC with function CyU3PUsbGetSpeed().

Always return CY_U3P_HIGH_SPEED.

But during connection device (denebola board) the standard message "this device can work faster, if you connect it to a USB3 port" is displayed.

Suggest that you can do here?

0 Likes
1 Solution
VlKh_2251656
Contributor II

The old driver USB3 was installed.

In any case, I plan To transfer the product to the customer along with the adapter PCI-E to USB3.

View solution in original post

0 Likes
9 Replies
VlKh_2251656
Contributor II

O, sorry.

Mainboard is not P5P43TD.

Is P5P43TD USB3.

0 Likes
KandlaguntaR_36
Moderator
Moderator

As per this comment " during connection device (denebola board) the standard message "this device can work faster, if you connect it to a USB3 port" is displayed ", the device is establishing the High-Speed connection. Hence, the API returning High-Speed.(working as expected).

Are you sure that you are connection to USB 3.0 Port on Host side?

Download USBLyzer (USBlyzer - USB Protocol Analyzer and USB Traffic Sniffer for Windows ) and see the connection type.

You can also connect any other USB 3.0 device (Pen Drive) and the connection established( High-Speed or Super-Speed) in USB Lyzer.

What is the firmware that you are using on your board?

Can you try USB Bulk Source Sink example firmware and collect the logs and see? Refer section 2.1 in the attached FX3 SDKTroubleshooting Guide.

VlKh_2251656
Contributor II

Can you try USB Bulk Source Sink example firmware and collect the logs and see?

Thanks.

Now I try it

0 Likes
Anonymous
Not applicable

This message is also shown if one of the upstream hubs are connected at HighSpeed instead of SuperSpeed. It's possible you have a device driver issue in the system, unrelated to Cypress, or are using a USB2 port on the system.

YangyangC_06
Employee

Hi Vladimir,

I assume that you indeed connect CX3 to the USB2.0 host or USB2.0 port. Please check that.

VlKh_2251656
Contributor II

Thank you very much for your response.

Physically, I connect Denebola to PC port USB3 (it's blue)

but I'm watching the program usbTreeView

This program shows that there is a logical connection to the port USB3

It's strange..

0 Likes
shkuc_292731
New Contributor II

Can you please update what happened ?

0 Likes
VlKh_2251656
Contributor II

The old driver USB3 was installed.

In any case, I plan To transfer the product to the customer along with the adapter PCI-E to USB3.

View solution in original post

0 Likes
shkuc_292731
New Contributor II

Ok. Thanks for the prompt response.

0 Likes