cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Ark
New Contributor

After CYUSBS236 DVK SDK installed, the USB Serial Configuration Utility can found device and programmed success. But there isn't any device can be found in USBSerialTestUtility.

I followd the user guide of CYUSBS236_User Guide --  3.3.4 I2C Configuration

There is some different with the document at my end :

1. As attached "capture" shows the cypress device driver cant be show in my device manager but the others USB Controller driver shows as document.

There are some questions at my end :

1. Does this DVK supports Windows 10 pro? 

2. Is there any latest driver required to update? I tried to update the SDK but it shows it already the latest version USBSerialTestUtility 1.0.1.80

 

 

0 Likes
1 Solution
MallikaK_22
Moderator
Moderator

Hello,

>> The USB Serial Test Utility only detects devices which are bound to Cypress vendor driver i.e. cyusb3 driver. Please confirm if you are using the vendor mode for I2C to test the functionality.

>> Kindly confirm if you installed the drivers ( CypressDriverInstaller_1.exe) from this page: https://www.cypress.com/documentation/software-and-drivers/usb-serial-software-development-kit 

You can refer to the Cypress USB-Serial Driver Installation Guide for the procedure.

Regards,

Mallika

Mallika

View solution in original post

0 Likes
2 Replies
MallikaK_22
Moderator
Moderator

Hello,

>> The USB Serial Test Utility only detects devices which are bound to Cypress vendor driver i.e. cyusb3 driver. Please confirm if you are using the vendor mode for I2C to test the functionality.

>> Kindly confirm if you installed the drivers ( CypressDriverInstaller_1.exe) from this page: https://www.cypress.com/documentation/software-and-drivers/usb-serial-software-development-kit 

You can refer to the Cypress USB-Serial Driver Installation Guide for the procedure.

Regards,

Mallika

Mallika

View solution in original post

0 Likes
Ark
New Contributor

Thanks Mallika,

     It is a mistake of my DVK PID which is different from the default value in USBSerialTestUtility, it has been corrected and found at my end. Thanks for your suggestions.

 

Best Regards

ArthurFan

 

 

0 Likes