cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

VlKh_2251656
Contributor II

Good day.

We made a custom video camera on chip CX3 similar to devkit Denebola.

Sometimes, when running, the current consumption of the microcontroller reaches 1 ampere.

Tell me please, what can it be connected with?

With the wrong setting of clock frequencies and clocking scheme (in particular, plt)?

Or are other reasons possible?

Thank you very much.

0 Likes
8 Replies
VlKh_2251656
Contributor II

May be wrong PLL registers settings of CX3 is reason of big cuurent ?

0 Likes
KandlaguntaR_36
Moderator
Moderator

Which firmware you are using?

Please share the snap shots of mipi confguration and uvc.c file to check whether PLL settings are correct.

Can you please describe the 1A current is consumed when the video is streaming?

0 Likes
VlKh_2251656
Contributor II

Yes, please.

// Configuration parameters for 5Mp @15FPS for the OV5640 sensor

CyU3PMipicsiCfg_t mipiCfg_5Mp_15 =  {

    CY_U3P_CSI_DF_YUV422_8_2,

    2,

    1,

    64,

    CY_U3P_CSI_PLL_FRS_500_1000M,

    CY_U3P_CSI_PLL_CLK_DIV_8,

    CY_U3P_CSI_PLL_CLK_DIV_8,

    0,

    CY_U3P_CSI_PLL_CLK_DIV_2,

    2592,

    0x01

};

// Configuration parameters for 1080p @30FPS for the OV5640 sensor

CyU3PMipicsiCfg_t mipiCfg_1080p30 =  {

    CY_U3P_CSI_DF_YUV422_8_2,     // dataFormat

    2,                          // numDataLanes

    1,                        // pllPrd

    62,                         // pllFbd

    CY_U3P_CSI_PLL_FRS_500_1000M, // pllFrs

    CY_U3P_CSI_PLL_CLK_DIV_8,   // csiRxClkDiv

    CY_U3P_CSI_PLL_CLK_DIV_8,   // parClkDiv

    0x00,                       // mclkCtl

    CY_U3P_CSI_PLL_CLK_DIV_8,   // mClkRefDiv

    1920,                       // hResolution

    0x01                        // fifoDelay

};

// Configuration parameters for 960p@30FPS for the OV5640 sensor

CyU3PMipicsiCfg_t mipiCfg_960p60 =

{

CY_U3P_CSI_DF_YUV422_8_2,      // dataFormat

2,                          // numDataLanes

1,                        // pllPrd

62,                          // pllFbd

CY_U3P_CSI_PLL_FRS_250_500M, // pllFrs

CY_U3P_CSI_PLL_CLK_DIV_4,    // csiRxClkDiv

CY_U3P_CSI_PLL_CLK_DIV_4,    // parClkDiv

0x00,                        // mclkCtl

CY_U3P_CSI_PLL_CLK_DIV_8,    // mClkRefDiv

1280,              // hResolution

0x01                        // fifoDelay

};

// Configuration parameters for VGA for the OV5640 sensor

CyU3PMipicsiCfg_t cfgUvcVgaNoMclk_SS =  {

    CY_U3P_CSI_DF_YUV422_8_2,       // dataFormat

    1,                            // numDataLanes

    0x1,                          // pllPrd

    90,                            // pllFbd

    CY_U3P_CSI_PLL_FRS_125_250M,    // pllFrs

    CY_U3P_CSI_PLL_CLK_DIV_2,     // csiRxClkDiv

    CY_U3P_CSI_PLL_CLK_DIV_8,     // parClkDiv

    0x00,                         // mclkCtl

    CY_U3P_CSI_PLL_CLK_DIV_8,     // mClkRefDiv

    640,                          // hResolution

    0x01                          // fifoDelay

};

0 Likes
VlKh_2251656
Contributor II

We check the total current consumption of the microcontroller CX3.

Unfortunately, we cannot measure the current consumption of each channel of the supply voltages separately.

We measure the current consumption on a shunt resistor connected to the power line of the USB cable.

Sometimes when the device is connected, the current consumption reaches about 1 Ampere.

0 Likes
abhinavg_21
Moderator
Moderator

Hi,

Please mention whether the device is working properly or not (even after consuming 1 Amps of current). Also tell me for how long it consumes 1 Amp current? Is it happening only for short duration of time? How much is the normal power consumption? I assume that your device is USB bus powered, correct me if I am wrong.

If possible, please share the schematics so that I can verify other devices as well.

Thanks & Regards

Abhinav

0 Likes
VlKh_2251656
Contributor II

Thank you very much

We have installed current protection in our kit.

Therefore, 10 ms after the current increase, the current protection is triggered.

After that, after one second, the device reconnects.

Everything, including chip CX3, remains "alive" and no damaging.

0 Likes
abhinavg_21
Moderator
Moderator

Hi,

Current protection circuit is cutting the power supply from the bus, so CX3 is getting restarted. Could you please try to debug the firmware and find at what point this abnormality is happening? Also I assume that it is working fine till that point in the firmware.

Thanks & Regards

Abhinav

VlKh_2251656
Contributor II

Many thanks

0 Likes