Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Not applicable



I am trying to use the eclipse CX3 configuration tool to add a new camera sensor but I am running into various troubles.


I have just installed the FX3 SDK FX3_SDK_Windows_v1.3.3.exe, and applied the (unfortunately this thing does not seem to have a version number).


The (outdated it seems, but there does not seem anything up to date) resources i am using are:


- The help found under:


 Help >  Help  Contents  >  Cypress  EZ-USB  Guides  >  EZ-USB  Suite  Guide  >  CX3  Configuration Utility


- The AN :AN90369_How_to_Interface_a_MIPI_CSI-2_Image_Sensor_With_EZ-USB_CX3.pdf, section 5.5  Configuring the MIPI CSI-2 Controller


For this test I have filled the "Image Sensor Configuration" tab with values corresponding to the "AN90369_How_to_Interface_a_MIPI_CSI-2_Image_Sensor_With_EZ-USB_CX3.pdf" document (except i added image support but that does not make a difference).


Now if I go to the CX3 Receiver Configuration tab I am greeted by a 'Multiple problems have occurred message" box with message: For input string: ",00". An error has occurred. See error log for more details. (cfr screenshot in attachment)


- Where is this error log located ?


- Where does he get his input strings from, ",00" . I was expecting  the cx3config.cycx file. but there is no ,00 in that file


- Maybe problem arises from , vs . for decimal separators (I am in Europe). Any workarounds ?


(I have more problems afterwards if I continue but since they might be a result of this one I restarted from clean workspace, imported the demo projects and will focus on the first problem before moving to the next)





3 Replies
Not applicable
        Can it be an issue caused by a non-English OS? Please tell us which OS/language you are using. As you suspect, there can be some ., problem associated with a particular OS language. Can you please check with a OS installed with English language?   
Not applicable

In your Windows language, you must choose decimal separator '.', probably you should have ',', or change it for English.

New Contributor

I have tried changing decimal separator to ".", but it did not help. But changing the language to English actually helped, thanks for the tip!

Cypress, do you plan to fix this issue or will you force all your customers to change OS settings as workaround for misbehaving IDE?