cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

New Contributor II

Hi,

I'm just staring with CYUSB3KIT-003 in Linux but I found a few issues.

I'm following EzUsbSuite_UG.pdf from Cypress/cyfx3sdk/doc/firmware/ and FX3_SDK_Linux_Support.pdf from Cypress/cyfx3sdk/

The problem I see is when I use exUsbSuite there is no CPP envoriment and there is no way to configure the debug mode.

Screenshot_20200311_135037.png

Screenshot_20200311_142713.png

0 Likes
Reply
1 Solution
Moderator
Moderator

Hello,

I have tried to reproduce the issue you are facing on Ubuntu 16.04 system

But i am getting the option of debug in the FX3 SDK 1.3.4 (EzUSBSuite) .

Screenshot from 2020-03-12 22-57-05.png

Please confirm that you are using the latest version of SDK  and have installed the SDK as per the steps mentioned

You can try reinstalling the SDK

Regards,

Rashi

Regards,
Rashi

View solution in original post

0 Likes
Reply
5 Replies
Moderator
Moderator

Hello,

Please refer to FX3_SDK_Linux_Support.pf with the FX3 SDK  which mentions debugging CYUSB3KIT-003 using OpenOCD

Please follow the steps and let me know if any query on this

Regards,

Rashi

Regards,
Rashi
0 Likes
Reply
New Contributor II

This do not answer the question. It's just a copy and paste from another question I have.

0 Likes
Reply
Moderator
Moderator

Hello,

I have tried to reproduce the issue you are facing on Ubuntu 16.04 system

But i am getting the option of debug in the FX3 SDK 1.3.4 (EzUSBSuite) .

Screenshot from 2020-03-12 22-57-05.png

Please confirm that you are using the latest version of SDK  and have installed the SDK as per the steps mentioned

You can try reinstalling the SDK

Regards,

Rashi

Regards,
Rashi

View solution in original post

0 Likes
Reply
New Contributor II

OK, So the development envoriment doesn't work on Arch Linux and Ubuntu 18.

I had to install ubuntu 16 to get working.

Can you guys make it work on Ubuntu 18?

Thanks

Lucas

0 Likes
Reply
Moderator
Moderator

Hello,

Thank you for the suggestion. I will forward this to respective team.

But you can try reinstalling the SDK  as per the steps mentioned in the section 2 of Using FX3 SDK on Linux Platforms

Regards,

Rashi

Regards,
Rashi
0 Likes
Reply