cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

MaPo_1297961
New Contributor

Hello!

I use Cypress FX3 in my design, so I've tested it with Stream In and Out examples. It works good with precompiled .img files and with rebuilt files too.

The loopback example works only when I load original .img file from Cypress. So, when I rebuilt that example project without any changes, it stops to work.

It looks like data output is OK, but there is no input data. As I discovered with Chipscope, the FLAGC never goes high, so FPGA FSM stucks on waiting.

Is it known problem? What should I change to fix it? I suppose, bug is somewhere in GPIF part.

Many thanks for help!

With regards,

Maksim

0 Likes
1 Solution
abhinavg_21
Moderator
Moderator

Hi,

Which version of FX3 SDK are you using. If it is FX3SDK 1.3.3 then please try to install the latest FX3 SDK 1.3.4 and try to built that.

http://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

-Regards

Abhinav

View solution in original post

2 Replies
abhinavg_21
Moderator
Moderator

Hi,

Which version of FX3 SDK are you using. If it is FX3SDK 1.3.3 then please try to install the latest FX3 SDK 1.3.4 and try to built that.

http://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

-Regards

Abhinav

View solution in original post

MaPo_1297961
New Contributor

Hi, Abhinav!

Yes, it was old version, so I've updated it to the latest one.

Now it works good as a Cypress precompiled project

Many thanks!

With regards,

Maksim

0 Likes