cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

ChRi_4661256
New Contributor

My system and setup:

Ubuntu 18.04, USB 2.0.   Device is a Commell MPX24794S card using a Cypress CY8C24794.   The cyusb_linux_1.0.4 package was installed according to the instructions in the README file. The active VID and PID was obtained from the command lsusb as VID = cece and PID = 7941.  The /etc/cyusb.conf file and the /etc/udev/rules.d/88-cyusb.rules file were modified according to other discussions found here. 

cyusb.conf changed to have cece     7941        Commell MPX24794S

88-cyusb.rules changed to have ATTR{idVendor}=="cece"   instead of ATTR{idVendor}=="04b4"

Results and observations:

trying to run cyusb_linux gives 2 error messages:  Error in opening device and Error opening library.

Commell documentation claims that the PID is 7940.  When the value is changes to this cyusb_linux loads but produces a command line response of No device found and there is no device listed in the running program.

cyusb_linux will also run with no device found if the original forms of cyusb.conf and 88-cyusb.rules are used.

Using what appears to be the correct information according to lsusb gives the most problems.

Please advise as to the next step.  Thank you.

0 Likes
1 Solution
YatheeshD_36
Moderator
Moderator

Hello,

Can you please use the latest linux SDK 1.0.5 from the FX3 SDK: https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

Do let me know if you are getting the same errors after using the latest SDK.

Thanks,

Yatheesh

View solution in original post

0 Likes
2 Replies
YatheeshD_36
Moderator
Moderator

Hello,

Can you please use the latest linux SDK 1.0.5 from the FX3 SDK: https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

Do let me know if you are getting the same errors after using the latest SDK.

Thanks,

Yatheesh

View solution in original post

0 Likes
ChRi_4661256
New Contributor

Yes this has solved the issue.  cyusb_linux now correctly loads and finds the device using the the VID and PID found by using lsusb in linux.   Thank you.

0 Likes