cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

saku_4625426
New Contributor

Hi,

We have implemented a code for FX2LP snapshot in Windows 7, its giving the proper image. But in Windows 10 giving the distorted image. Can you help to solve this problem.

Thank you...

0 Likes
Reply
1 Solution
YatheeshD_36
Moderator
Moderator

Hello,

Seems to be a problem in the host application.

You can use the control center application on both the OS and check if the data received is the same by doing a IN transfer with the expected amount of data. Ideally when you use the control center the data will be identical.

Also cyusb3 1.2.3.20 is the latest driver, please upgrade you driver versions and the corresponding host application in both windows 7 and windows 10.

Best Regards,

Yatheesh

View solution in original post

0 Likes
Reply
7 Replies
YatheeshD_36
Moderator
Moderator

Hello,

Can you please let me know if you are using Slave FIFO mode in FX2LP and which driver is the device(FX2LP) bound to? Are you using your own driver and host application of UVC driver.

Best Regards,

Yatheesh

0 Likes
Reply
saku_4625426
New Contributor

Hi,

Yes, i am using Slave FIFO mode in FX2LP and windows 10, 64 bit with the device bound to CyUSB.sys driver.

Not using the UVC Driver.

Thank you..

0 Likes
Reply
YatheeshD_36
Moderator
Moderator

Hello,

Can you please let me know the driver name and version. This can be checked in device manager under properties of the particular device -> driver tab and also the driver details .

You can send me a screen shot of the same.

Please refer to the attached screenshot.

pastedImage_0.png

Best Regards,

Yatheesh

0 Likes
Reply
saku_4625426
New Contributor

Hi,

And, also verify the code in windows 10 which was given proper image( conform that in your pc whether it is giving full r not).

pastedImage_0.png

0 Likes
Reply
YatheeshD_36
Moderator
Moderator

Hello,

Can you please check if its the same driver version the device is getting bound to in both windows 10 and windows 7.

The device will sample data irrespective of the host operating system. The problem might be in the host controller, driver or the host application. Please make sure that the driver and the host application is the same in both windows 10 and windows 7.

Also are you using a custom host application for the same?

Thanks,

Yatheesh

0 Likes
Reply
saku_4625426
New Contributor

Hi,

In windows 7, this is the version, i installed this version in windows 10(In windows 7 version will same, continuously giving the cleared image. But in windows 10 only one time the image is giving, after building the project also not getting the image proper).

pastedImage_0.png

0 Likes
Reply
YatheeshD_36
Moderator
Moderator

Hello,

Seems to be a problem in the host application.

You can use the control center application on both the OS and check if the data received is the same by doing a IN transfer with the expected amount of data. Ideally when you use the control center the data will be identical.

Also cyusb3 1.2.3.20 is the latest driver, please upgrade you driver versions and the corresponding host application in both windows 7 and windows 10.

Best Regards,

Yatheesh

View solution in original post

0 Likes
Reply