cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

user_63082
New Contributor

Hi,

I'm trying to do a driver with the cyusb suite for my FX2 chip.

I saw some people are using WDF Coinstaller for their Cypress device, so how do I know if I have to use the WDF Coinstaller installation in my INF file ?

0 Likes
Reply
1 Solution
YatheeshD_36
Moderator
Moderator

Hello,

Windows 8.1 and later versions of operating systems has co-installer integrated into the OS kernel.

So, If the driver is targeted to windows 8.1 or later versions the co-installers are not necessary.

Please check KmdfLibraryVersion in the current driver package .inf file which you have. If the version is 1.11 or lower then a WDF co-installer is needed, if the version is 1.13 or higher then they are not needed:

kmdf version 1.13 will run on windows 8.1 or later.

kmdf version 1.15 will run on windows 10(TH1) or later.

Best Regards,

Yatheesh

View solution in original post

0 Likes
Reply
2 Replies
YatheeshD_36
Moderator
Moderator

Hello,

Windows 8.1 and later versions of operating systems has co-installer integrated into the OS kernel.

So, If the driver is targeted to windows 8.1 or later versions the co-installers are not necessary.

Please check KmdfLibraryVersion in the current driver package .inf file which you have. If the version is 1.11 or lower then a WDF co-installer is needed, if the version is 1.13 or higher then they are not needed:

kmdf version 1.13 will run on windows 8.1 or later.

kmdf version 1.15 will run on windows 10(TH1) or later.

Best Regards,

Yatheesh

View solution in original post

0 Likes
Reply
user_63082
New Contributor

Thank you for the explanation !

0 Likes
Reply