cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

Anonymous
Not applicable

I have the following board (in attachment). and need help to send data from xilinx to windows application via usb cyrpess cy7c68013a-56pvxc

0 Likes
1 Solution
SrinathS_16
Moderator
Moderator

Hello,

- After you program the FPGA, does the device come up as "Unknown Device" in the device manager or is it not enumerating at all?

- In case the device does not come up at all in the device manager, kindly, probe the RESET# pin of the FX2LP device and check if the FPGA is driving it LOW.

Best regards,

Srinath S

View solution in original post

7 Replies
Hemanth
Moderator
Moderator

Hi,

Please let us know if you are facing any problem in implementing the same.

And did you refer to the following application note:

http://www.cypress.com/file/44551/download

Regards,

Hemanth

Hemanth
Anonymous
Not applicable

Sir, As you see in "AVA6SLXBoardSchematic-v2.pdf: i have no CLKOUT

connection it is float, i use dcm to generate 48 MHz from 50 MHz and use it

as clk in fx2lp_loopback,

and i do the following:

1- change ucf file according to my board.

2- in"FX2LP firmware" i change product_id to 1003 according to what shown

in Device Manager

3- when i download bitstrem to xilinx via "platform calbe usb programmer" ,

cypress driver disappear from device manager

here is the full code in attachment

0 Likes
Anonymous
Not applicable

i have no sync signal,and

Sir, As you see in "AVA6SLXBoardSchematic-v2.pdf: i have no CLKOUT

connection it is float, i use dcm to generate 48 MHz from 50 MHz and use it

as clk in fx2lp_loopback,

and i do the following:

1- change ucf file according to my board.

2- in"FX2LP firmware" i change product_id to 1003 according to what shown

in Device Manager

3- when i download bitstrem to xilinx via "platform calbe usb programmer" ,

cypress driver disappear from device manager

here is the full code in attachment

0 Likes
Sananya_14
Moderator
Moderator

Hello,

-Is your device enumerating properly before connecting to the FPGA? Please let us know if there are any changes in the firmware apart from the VID, PID.

Best Regards,

Sananya

Anonymous
Not applicable

Yes it works , i use Cypress Suite USB 3.4.4,Control Center. first it show vis=04b4 and pid=8613, and when i download hex file it show vid=04b4, pid=1003. i send .hex and receive it correctly

but in my board AVA6SLXBoardSchematic-v2.pdf 

i can not send data xilinx->CY7C68013->pc

0 Likes
SrinathS_16
Moderator
Moderator

Hello,

- After you program the FPGA, does the device come up as "Unknown Device" in the device manager or is it not enumerating at all?

- In case the device does not come up at all in the device manager, kindly, probe the RESET# pin of the FX2LP device and check if the FPGA is driving it LOW.

Best regards,

Srinath S

View solution in original post

Anonymous
Not applicable

i have done the following and it receive constant data from xilinx .

i,e: xilinx->usb>pc-labview is OK now

0 Likes