cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

Anonymous
Not applicable
        Basicly. I have a USB FX2 programmed for an arcade game known as "Pump it up" by Andamiro, And I have been looking for a way to test input under a windows environment and possibly use instead of having to boot up an arcade machine everytime I wanted to work with the hardware. I have many files for the software as well as firmware information from one of the games HDDs, But after installing cypress, It never detected the EZUSB FX2 device connected. Yes I had power going to it. Anybody know a simple way to get this hardware functioning with windows?   
0 Likes
8 Replies
Anonymous
Not applicable

 Hi,

   

 

   

Can you detail your application a bit more. Are you trying to bind it to Cy driver and access through a GUI? If so, did you check if it is bound properly in the device manager?

   

 

   

Regards,

   

Gayathri

0 Likes
Anonymous
Not applicable

 I have all of the drivers and c/h files for it, and have connected it to the desktop. But Cypress Suite USB 3.4.7 does not read it as connected, Once I finally do get it connected I want to use the button input as a joypad in windows.

Connected it, powered it up, And I get nothing in cypress.

Here are some of the files if you want to have a look

   

https://mega.co.nz/#!zwBinZgZ!BJZXSxP_PeLC_6K2i8-x4lIg0W9wnJixm_j_K-s8FUU

   
        
0 Likes
Anonymous
Not applicable

 Eh, I just decided to upload a picture.

Windows detects it just fine in the device manager....but, Its not detected at all by the console.

http://i5.minus.com/iM7maSi2fZtOW.png

0 Likes
Anonymous
Not applicable

 Hi,

   

 

   

As can bee seen from the pic that you had attached, the devcie is bound using LIBUSB driver I believe. In that case, it is not expected for the device to show up in CyConsole/ Control Center. Control Center (from SuiteUSB 3.4.7) shows up devices bound to either CyUSB.sys, HID/ MSC driver.

   

 

   

Regards,

   

Gayathri

0 Likes
Anonymous
Not applicable

 Hi,

   

 

   

Why do you want the device to show up in Control Center. Please detail what you are trying to do.

   

 

   

Regards,

   

Gayathri

0 Likes
Anonymous
Not applicable

 Im simply plugging it in with power going to the device.

   

 

   

Even after unbinding it to the libusb driver it would not work or show up as a connected device. Forgive me for being new to the lubusb, The device has always been config`d and ready to go, Never had to set it up before today.

0 Likes
Anonymous
Not applicable

 Hi, 

   

 

   

When you say unbinding from libusb, did you bind it to Cypress driver (cyusb.sys) ? Are trying all tehse for some experimental purpose? Please explain why you want the device to show up in Control Center?

   

 

   

Regards,

   

Gayathri

0 Likes
Anonymous
Not applicable

 hello

   
I am a technician like you and me know if you have achieved recognition as the I / O board as pad
0 Likes