cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

New Contributor

Dear support,

During the communication between the FX3 and the HOST (windows computer), I get an extra response packet from the FX3 (that is malformed by the way) to the GET DESCRIPTOR request configuration sends by the host.

Like you can see in the picture, the event n°527 GET DESCRIPTOR request configuration gets its response, with no errors, from the FX3 with the event n°528 GET DESCRIPTOR response configuration. The problem is that the event n°530 also responds to the event n°527 and is malformed.

cypress.PNG

I need your help to know why there would be a second response to a request that is already treated. Because of that, I have a SET CONFIGURATION done that recreate all my threads.

Thank you for Help,

Cedric

edit : all request on descriptor are handled by the functions of Cypress, not by my code.

Ce message a été modifié par : Cédric JAYET-GRIFFON

0 Likes
Reply
1 Solution
Employee

This can be due to multiple reasons. Check whether the enumeration is fine with FX3 SDK code examples to ensure the hardware is working fine. Also check when the CyU3PConnectState() API is called in the enumeration routine. Usually this should be called in the end of initialization section.

View solution in original post

0 Likes
Reply
1 Reply
Employee

This can be due to multiple reasons. Check whether the enumeration is fine with FX3 SDK code examples to ensure the hardware is working fine. Also check when the CyU3PConnectState() API is called in the enumeration routine. Usually this should be called in the end of initialization section.

View solution in original post

0 Likes
Reply