cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

Contributor

Hi Sir,

I follow SuperSpeed Explorer Kit User Guide_001-93186_A.pdf to do debug with EZ USB suite,but return me some error as below,please help to check.

44^error,msg="localhost:3333: \323\311\323\332\301\254\275\323\267\275\324\332\322\273\266\316\312\261\274\344\272\363\303\273\323\320\325\375\310\267\264\360\270\264\273\362\301\254\275\323\265\304\326\367\273\372\303\273\323\320\267\264\323\246\243\254\301\254\275\323\263\242\312\324\312\247\260\334\241\243\r\n."

(gdb)

45 monitor reset halt

monitor reset halt

"monitor" command not supported by this target.

&"monitor reset halt\n"

&"\"monitor\" command not supported by this target.\n"

45^error,msg="\"monitor\" command not supported by this target."

(gdb)

46 monitor mww 0xFFFFF014 0xFFFFFFFF

&"monitor mww 0xFFFFF014 0xFFFFFFFF\n"

&"\"monitor\" command not supported by this target.\n"

monitor mww 0xFFFFF014 0xFFFFFFFF

"monitor" command not supported by this target.

...

65 load

load

You can't do that when your target is `exec'

&"load\n"

&"You can't do that when your target is `exec'\n"

65^error,msg="You can't do that when your target is `exec'"

(gdb)

66-exec-continue

66^error,msg="The program is not being run."

(gdb)

Thanks,

Leo

0 Likes
Reply
1 Solution
Moderator
Moderator

Hello Leo,

I tried to reproduce the problem at my end. (refer attachment).

To solve this issue you need to follow the steps from software setup (page: 36) of the document you mentioned in your post.

The configuration file arm926ejs_FX3.cfg need to be added.

The document you are referring is not the latest version.

Note: The path to directories will differ if you are using the newer SDK with this document

You can refer to Section 3.2 of  EzUsbSuite_UG - Debugging with OpenOCD in the newer version of SDK 1.3.4  https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit 

Regards,

Rashi

Regards,
Rashi

View solution in original post

3 Replies
Moderator
Moderator

Hi Leo,

- It seems that you using OpenOCD for denugging. Please Confirm.

- Can you share the prints from other console (Refer attachment)

- Are you following all the steps mentioned in the user guide that you pointed to in the post? Please confirm.

- If you are using OpenOCD what is the version? 0.8.0 version is recommended

  If using Segger J Link Install latest J Link GDB Server software

Regards,

Rashi

Regards,
Rashi
0 Likes
Reply
Contributor

Hi Rashi,

1. I haven't used OpenOCD ,my console prints as below

pastedImage_1.png

2. I followed all the steps mentioned in the user guide from page 39 to page  42.

Thanks,

Leo

0 Likes
Reply
Moderator
Moderator

Hello Leo,

I tried to reproduce the problem at my end. (refer attachment).

To solve this issue you need to follow the steps from software setup (page: 36) of the document you mentioned in your post.

The configuration file arm926ejs_FX3.cfg need to be added.

The document you are referring is not the latest version.

Note: The path to directories will differ if you are using the newer SDK with this document

You can refer to Section 3.2 of  EzUsbSuite_UG - Debugging with OpenOCD in the newer version of SDK 1.3.4  https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit 

Regards,

Rashi

Regards,
Rashi

View solution in original post