cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

New Contributor II

Visual Studio 2015 first doesn't like the project file and requires you to upgrade the project file. Second

when you do get to where you can build it gives 53 errors. I suspect there is some header file missing.

Any ideas ?

Severity    Code    Description    Project    File    Line    Suppression State

Error    C2653    'System': is not a class or namespace name    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    3   

Error    C2871    'Reflection': a namespace with this name does not exist    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    3   

Error    C2653    'System': is not a class or namespace name    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    4   

Error    C2871    'CompilerServices': a namespace with this name does not exist    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    4   

Error    C2337    'AssemblyTitleAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    11   

Error    C2337    'AssemblyDescriptionAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    12   

Error    C2337    'AssemblyConfigurationAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    13   

Error    C2337    'AssemblyCompanyAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    14   

Error    C2337    'AssemblyProductAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    15   

Error    C2337    'AssemblyCopyrightAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    16   

Error    C2337    'AssemblyTrademarkAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    17   

Error    C2337    'AssemblyCultureAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    18   

Error    C2337    'AssemblyVersionAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    31   

Error    C2337    'AssemblyDelaySignAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    55   

Error    C2337    'AssemblyKeyFileAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    56   

Error    C2337    'AssemblyKeyNameAttribute': attribute not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\AssemblyInfo.cpp    57   

Error    C2871    'System': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    8   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    9   

Error    C2871    'ComponentModel': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    9   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    10   

Error    C2871    'Collections': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    10   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    11   

Error    C2871    'Forms': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    11   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    12   

Error    C2871    'Data': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    12   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    13   

Error    C2871    'Drawing': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    13   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    14   

Error    C2871    'Threading': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    14   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    15   

Error    C2871    'Diagnostics': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    15   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    16   

Error    C2871    'Reflection': a namespace with this name does not exist    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    16   

Error    C2059    syntax error: 'public'    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    19   

Error    C2653    'System': is not a class or namespace name    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    19   

Error    C2143    syntax error: missing ';' before '{'    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    20   

Error    C2447    '{': missing function header (old-style formal list?)    Streamer    c:\cypress\cypress suite usb 3.4.7\cyapi\examples\streamer\Streamer.h    20   

Error    C2653    'System': is not a class or namespace name    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    14   

Error    C2871    'Forms': a namespace with this name does not exist    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    14   

Error    C2653    'System': is not a class or namespace name    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    22   

Error    C2065    'CurrentThread': undeclared identifier    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    22   

Error    C2227    left of '->ApartmentState' must point to class/struct/union/generic type    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    22   

Error    C2065    'STA': undeclared identifier    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    22   

Error    C2653    'Application': is not a class or namespace name    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    26   

Error    C2061    syntax error: identifier 'Form1'    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    26   

Error    C3861    'Run': identifier not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    26   

Error    C2061    syntax error: identifier 'Exception'    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    28   

Error    C2310    catch handlers must specify one type    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    28   

Error    C2653    'MessageBox': is not a class or namespace name    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    30   

Error    C2065    'e': undeclared identifier    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    30   

Error    C2227    left of '->StackTrace' must point to class/struct/union/generic type    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    30   

Error    C2227    left of '->Message' must point to class/struct/union/generic type    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    30   

Error    C3861    'Show': identifier not found    Streamer    C:\Cypress\Cypress Suite USB 3.4.7\CyAPI\examples\Streamer\Streamer.cpp    30   

0 Likes
Reply
1 Solution
Moderator
Moderator

Hello,

- Right click on the 'Streamer' project and choose 'Properties'.

- Under the 'Linker' tab, choose 'Input'.

- In the 'Additional Dependencies' box, modify the below statement

C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\library\cpp\lib\x86\

to

C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\library\cpp\lib\x86\CyAPI.lib

Best regards,

Srinath S

View solution in original post

0 Likes
Reply
28 Replies
Moderator
Moderator

Hello,

The host application examples present in the Cypress Suite USB 3.4.7 were built using the Visual Studio 2008 and hence may not compatible with the later versions of Visual Studio. Kindly, install the FX3 SDK from the below link and use the streamer application from the path mentioned below.

FX3 SDK - http://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-...

Streamer Application path - C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\application\cpp\streamer

Best regards,

Srinath S

New Contributor II

Ok I downloaded and installed the FX3 SDK. When I try to build the streamer project in Visual Studio 2015    I get an error LNK1104 Can not open file x86.obj. I suspect its a path problem. Any ideas ?

0 Likes
Reply
Moderator
Moderator

Hello,

- Right click on the 'Streamer' project and choose 'Properties'.

- Under the 'Linker' tab, choose 'Input'.

- In the 'Additional Dependencies' box, modify the below statement

C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\library\cpp\lib\x86\

to

C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\library\cpp\lib\x86\CyAPI.lib

Best regards,

Srinath S

View solution in original post

0 Likes
Reply
New Contributor II

Ok, the streamer application builds correctly after the change in properties is made.

Upon trying to debug the application I find that the connected devices pull down control is empty.

There is a Cypress CY8CKIT-059 PSOC 5LP Prototyping kit attached to this PC which is programmed

with AN56377 project 3 in it.

Any ideas why the connected devices pull down control is empty ?

0 Likes
Reply
Moderator
Moderator

Hello,

The Streamer application only identifies the device connected to the CyUSB3.SYS driver. I think the CY8CKIT-059 PSoC 5LP Kit does not bind to this driver. This is the reason why Streamer does not list the device.

Best regards,

Srinath S

0 Likes
Reply
New Contributor II

I have had issues with the CyUSB3.sys driver in the past so that doesn't surprise me.

I believe my PC is using the PSOCUSB3.sys device driver. AN56377 specifically uses

the Streamer application in project 3. Is there some kind of way to test the Project 3

outside of the Streamer application ?

0 Likes
Reply
Moderator
Moderator

Hello,

Bind the device manually to CYUSB3.SYS driver and use the Streamer application to test the project.

Best regards,

Srinath S

0 Likes
Reply
New Contributor II

Ok, I got the CYUSB3.sys to bind to my board. So now the Streamer application starts up with

a connected devices field which is populated with the description in the device driver .inf file.

Unfortunately, the endpoint pull down field is still empty.  Any ideas ?

The AN56377 file probably needs to be updated with these changes.

Randy

0 Likes
Reply
Moderator
Moderator

Hello Randy,

- I was able to successfully see the endpoint on the C++ Streamer application. Please find the attachment.

- Kindly, check the PSoC firmware with the application note and ensure that you have configured the same.

Best regards,

Srinath S

0 Likes
Reply
New Contributor II

Hmm. This is a bit annoying. Ok, I went back through the AN56377 steps to build up project 3. Nothing seemed to change. So I rebuilt and programmed the board. I started the Streamer application and the endpoint is there this time. Uggh. The only issue that I can see with it, is that the transfer rate control is not updating. It just remains at zero through the whole start/stop sequence. Good and bad packets updates, and the show transferred data updates. Any ideas ?

0 Likes
Reply
Moderator
Moderator

Hello,

Please share the screenshot of the Streamer application. When there is a successful data transfer, the 'Transfer Rate' gets updated automatically as seen in the attached screenshot.

Kindly, let me know if you have made any changes to the Streamer application source with regard to the 'Transfer Rate' Control.

Best regards,

Srinath S

0 Likes
Reply
New Contributor II

The only changes that I have made are to the project 3 of the AN56377. They are related to changing the PID. Nothing on the Streamer project yet. The endpoint on the Streamer project has disappeared again on

the Streamer.

Randy

error1.jpg

I will keep trying on the transfer issue. To date unplugging and replugging the device makes no difference.

0 Likes
Reply
New Contributor II

Further digging into the system reveals that the device driver CYUSB3.sys is not loading correctly. In

Windows device manager you can see that the driver tries to load but fails with a code of 10. I am trying to use the driver configuration of:

VID_04B4&PID_0003&MI_02.DeviceDesc="USB-UART LP Vendor MFG"

for testing purposes. Any ideas ?

0 Likes
Reply
New Contributor II

One other item that might be worth mentioning is that this PC is an x64 based systems.

0 Likes
Reply
New Contributor II

After changing the firmware configuration settings for the PID to 1003 the driver loaded and you could see the information in the Streamer application for about ten minutes. Then after restarting the Streamer application the endpoint is no longer available. The device driver seems to be stable for the moment. Any idea on the endpoints ?

0 Likes
Reply
Moderator
Moderator

Hello Randy,

You should be choosing the 'Cypress FX2LP StreamerExample Device' in the 'Connected Devices' drop down list of Streamer application and NOT the 'USB-UART LP Vendor MFG' device. Please look at the below screenshot.

pastedImage_0.png

- Streamer application when built with x86 configuration should work fine on both x86 and x64 based systems.

Best regards,

Srinath S

0 Likes
Reply
New Contributor II

Ok, so if I wish to test other VID/PID values what is valid and appropriate to work with this device driver ?

The progress bar still does not work. See below.

error3.png

0 Likes
Reply
Moderator
Moderator

Hello Randy,

- If you have not modified the Streamer application source code pertaining to the calculation of XferRate parameter, the value should be shown on the progress bar. Please disable the 'Show Transferred Data' check box and see if the throughput is displayed.

- Make sure that you are selecting the Cypress FX2LP Streamer Example Device when you find that no endpoints are being displayed. Kindly, share the screenshot of this situation.

Best regards,

Srinath S

0 Likes
Reply
New Contributor II

Actually what happens is boot my computer and the on running the Streamer application works. Then I kill the application and restart it. Then the endpoint is longer present even if I restart it multiple times.

error4.png

0 Likes
Reply
New Contributor II

I also tried the prebuilt version of Streamer in the Release directory and it had the same problems with endpoints as the version that I built.

While running the Streamer application you can see that the progress control is not changing below.

error6.png

0 Likes
Reply
Moderator
Moderator

Hello Randy,

- Kindly, check using the Cypress USB Control Center if there is any data that is being received on the endpoint 0x81. To perform this, you can use the 'Transfer Data' button under the 'Data Transfers' tab of the Control Center.

- Please share the Streamer.exe file that you are using.

Best regards,

Srinath S

0 Likes
Reply
New Contributor II

When I was trying to test with the USB Control Center:

ISOC device is not listed in the Control Center.

No Cypress FX2LP Streamer Device in Windows computer management.

rebooted

unplugged Cypress FX2LP device

No Cypress FX2LP Streamer Device in Windows computer management.

Tried to install device driver software from disk.

This device cannot start/ VID/PID are unknown.

Tried to install device driver software from disk. Returns code 10

Device can not start.

Reprogrammed the device from PSOC 4.2  That seems to have returned

us to working status.

I reran the Control Center and the Streamer Application. The output

is shown below.

error7.png

I reran the Control Center and the Streamer Application. The output

of the USB Control Center showed that the Cypress FX2LP Streamer

Device was no longer present in the system even though no reboot

had occurred and the Cypress FX2LP Streamer Device was still working

properly according to the Windows Management Center.

Any ideas ?

0 Likes
Reply
New Contributor II

I have attached an executable of Streamer to this message.

0 Likes
Reply
New Contributor II

This is still an issue.

0 Likes
Reply
New Contributor II

Lately I find that the PID value is not changing even after being reprogrammed in PSOC

Creator 4.2 . It just stays the same value 0003. Any ideas ?

0 Likes
Reply
Employee

Are you facing the this issue with Streamer C#based App as depicted in AN.

Please don't try C++ based streamer application.

I have tried the project3 on AN56377 there is no issue with it with C# based Streamer application.

This C++ based streamer application issue of missing endpoint field  options appears to be system specific

0 Likes
Reply
New Contributor II

Hmmm. Well using the C# version does seem to allow the endpoints to display correctly. The

throughput display does not seem to be updating still.

When I try to use the USB Control Center, it does seem to retain the entries in the left pane through

restarts of the application but trying to send data through USB Control Center does not seem to be

working correctly.

The setting of the PID value seems to be working for the moment.

Any ideas ?

error9.png

0 Likes
Reply
Employee

Hi Randy,

Please create another thread for resolution of any  other issue other than for what the Thread was created.

Each thread correspond to resolution of one issue for which the thread is created.

0 Likes
Reply