cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

JeHu_3414236
Contributor II

I am using my own board and I cannot connect to the Cypress config tool.  It is detected by the tool but fails on connection.  I can use the COM port without any problems.  I didn't have this problem with the CYUSBS234 kit.  Does anyone know what is the problem?  This is the image of the error:

config.png

0 Likes
Reply
1 Solution
Sananya_14
Moderator
Moderator

Hello,

-Please let us know the part number you are using. Is it the same one as the DVK?

-Please use the USB-Serial Configuration Utility from the USB-Serial SDK and let us know if the error occurs.

Best Regards,

Sananya

View solution in original post

0 Likes
Reply
6 Replies
Sananya_14
Moderator
Moderator

Hello,

-Please let us know the part number you are using. Is it the same one as the DVK?

-Please use the USB-Serial Configuration Utility from the USB-Serial SDK and let us know if the error occurs.

Best Regards,

Sananya

View solution in original post

0 Likes
Reply
JeHu_3414236
Contributor II

I am using CY7C65211A.  The DVK uses CY7C65211.  I used the utility from the SDK and it still has error.  This is my schematic.  Another Cypress engineer said to make these changes regarding a different problem:

- Since VDDD is less than 2V, it is recommended to connect the VCCD pin to VDDD and not use a 1uF capacitor.

- Please ensure that you have ferrite bead on the VBUS pin of USB connector.

- It is necessary to connect the nXRES pin to a reset circuit.

Do these affect this problem?

usb1.png

0 Likes
Reply
Sananya_14
Moderator
Moderator

Hello,

Is your device enumerating properly in the device manager when it is not detected by the Configuration Utility? Please make the changes to your schematic and let us know the update.

Best Regards,

Sananya

0 Likes
Reply
JeHu_3414236
Contributor II

The device enumerates properly according to Windows Device Manager.  There is no error icon by any device.  I will try the changes on the next board.

0 Likes
Reply
Sananya_14
Moderator
Moderator

Hello,

Please let us know if you are still getting an error in the Utility after making the changes to the board?

Best Regards,

Sananya

0 Likes
Reply
JeHu_3414236
Contributor II

I have decided to use a PSoC MCU with USB instead of the CY7C65211 so I will not make another board with these changes.  Thanks.

0 Likes
Reply