cancel
Showing results for 
Search instead for 
Did you mean: 

USB Hosts Hubs Transceivers

New Contributor II

Hello Team,

We trying to configure the CYUSB3343 Customized Board.

USB is getting detected but shown as a unknown device. Attached error image for refernce

Here we connected USB Type A to Type C 3.1 Cable to PC port for configuration from HX3C Customized Board via POGO Pins (J92 to J114).

Also attached schematics for reference.

Kindly suggest the possible solution to fix the problem.

Best Regards

Pooja

Message was edited by: Rajath Bhargav

0 Likes
Reply
1 Solution
Moderator
Moderator

Hi pooja_3939176,

You can find the Cypress Vendor Driver in the HX3 blaster plus installation directory under HX3 Blaster Plus\drivers

To bind to vendor driver, go to device manager and right click on the USB Hub.

Select properties>Driver>Update Driver>"Browse My Computer">"Let me pick from list of available drivers"> Click on "Have Disk">Browse

Select the path of the driver file in location HX3 Blaster Plus\drivers and click "OK".

If this does not solve the issue, then I would recommend checking the USB traces for compliance and signal quality.

Regards,

Rajath

View solution in original post

3 Replies
Moderator
Moderator

Hi Pooja,

Please see KBA#223292 which explains this error.

  • Have you used a Type-C receptacle to connect the board to Type-C plug of the C-A cable?

Regards,

Rajath

New Contributor II

Hello Sir,

We followed proper guidelines as per the suggestion. Still it is recognizing as unknown device.

Yes, we connected Type C receptacle board to mother card.

In cypress blaster tool reference document, suggesting to unbound the windows driver to bound the cypress vendor driver.

Kindly suggest how to unbound the windows driver to bound cypress vendor driver and where we can get cypress vendor?

Regards

Pooja

0 Likes
Reply
Moderator
Moderator

Hi pooja_3939176,

You can find the Cypress Vendor Driver in the HX3 blaster plus installation directory under HX3 Blaster Plus\drivers

To bind to vendor driver, go to device manager and right click on the USB Hub.

Select properties>Driver>Update Driver>"Browse My Computer">"Let me pick from list of available drivers"> Click on "Have Disk">Browse

Select the path of the driver file in location HX3 Blaster Plus\drivers and click "OK".

If this does not solve the issue, then I would recommend checking the USB traces for compliance and signal quality.

Regards,

Rajath

View solution in original post