cancel
Showing results for 
Search instead for 
Did you mean: 

USB Hosts Hubs Transceivers

NaMo_1534561
New Contributor II

Hello,

My customer is considering HX3.

The host is running Linux OS, the version is Kernel 4.9, and the OS is Ubuntu 18.04.

The datasheet states that the HX3 is compatible with Linux kernel version 3.11, but is the Generic hub class driver for Kernel 4.9 also compatible?

Regards,

Naoaki Morimoto

0 Likes
1 Solution
Sananya_14
Moderator
Moderator

Hello Naoaki Morimoto-san,

HX3 uses the generic hub class driver provided by Linux and Kernel version 4.9 also includes the support for it so HX3 will be compatible and can be used. The Kernel version 3.11 is included in the datasheet since it would have been the latest one when the datasheet was created.

Best Regards,

Sananya

View solution in original post

0 Likes
2 Replies
Sananya_14
Moderator
Moderator

Hello Naoaki Morimoto-san,

HX3 uses the generic hub class driver provided by Linux and Kernel version 4.9 also includes the support for it so HX3 will be compatible and can be used. The Kernel version 3.11 is included in the datasheet since it would have been the latest one when the datasheet was created.

Best Regards,

Sananya

View solution in original post

0 Likes
NaMo_1534561
New Contributor II

Hello Sananya-san,

Thank you for reply.

Your answer solved my question.

Best Regards,

Naoaki Morimoto

0 Likes