cancel
Showing results for 
Search instead for 
Did you mean: 

USB Hosts Hubs Transceivers

CAMSCLE
New Contributor

Hello,

I  have configured the HX3 CYUSB3314 - 88 pin through the HX3 Blaster plus SW, and set the EMBEEDED HUB BYTE to 1, because my USB Upstream link cannot be removed by a user ( Embeeded in a product). My Hub is powered externally ( VBUS is not used) . 

However, when i cut the Vbus Upstream wire to simulate a default, or a perturbation, the Hub detect it and disconnect. Is it the appropriate and expected behaviour ? What is the purpose of this setting ?

I'm currently using the ihx3_revb_b7 firmware.

Thank you for your help,

 

0 Likes
1 Solution
Sananya_14
Moderator
Moderator

Hello,

Please let us know what is the current connection on VBUS_US pin? Does the hub enumerate when the pin is left unconnected from power-on?

Please refer to the KBA for details on the setting, it ideally shouldn't consider the VBUS on the pin for disconnect/connect.

Kindly also confirm if the modified settings have been programmed correctly onto the EEPROM by resetting the hub and reading back.

Best Regards,
Sananya

View solution in original post

0 Likes
1 Reply
Sananya_14
Moderator
Moderator

Hello,

Please let us know what is the current connection on VBUS_US pin? Does the hub enumerate when the pin is left unconnected from power-on?

Please refer to the KBA for details on the setting, it ideally shouldn't consider the VBUS on the pin for disconnect/connect.

Kindly also confirm if the modified settings have been programmed correctly onto the EEPROM by resetting the hub and reading back.

Best Regards,
Sananya

View solution in original post

0 Likes