cancel
Showing results for 
Search instead for 
Did you mean: 

USB Hosts Hubs Transceivers

TeMa_2997106
Contributor II

There is a phenomenon that the voltage drops to 1V for about 400ms during OS boot. It occurs on both the created board and CY4608.

Attach the waveform.

TEK0051.jpg

ch1 (yellow): U4 Pin1 (nENP1)
ch2 (blue): VBUS

My perception is that a reset is issued to the hub when the OS USB driver is initialized, and the HX2VL receives it and controls the Enable signal of the power supply IC. Is it correct? If yes, is this behavior as specified? Is there a time limit for making the Enable signal Inactive?

Thanks,
Tetsuo

0 Likes
1 Solution
Sananya_14
Moderator
Moderator

Hi Tetsuo-san,

Yes, my understanding is the same since the hub would remain connected to the host during reboot and the power enable nEP1 pin will not be asserted till a Set Feature (Port Power) command is sent from the host after Reset. 

Please note that the timing is host dependent and you could take USB traces using an analyzer on the upstream port to help check if HX2VL is behaving correctly as per commands from the host.

Best Regards,
Sananya

View solution in original post

2 Replies
Sananya_14
Moderator
Moderator

Hi Tetsuo-san,

Yes, my understanding is the same since the hub would remain connected to the host during reboot and the power enable nEP1 pin will not be asserted till a Set Feature (Port Power) command is sent from the host after Reset. 

Please note that the timing is host dependent and you could take USB traces using an analyzer on the upstream port to help check if HX2VL is behaving correctly as per commands from the host.

Best Regards,
Sananya

View solution in original post

TeMa_2997106
Contributor II

Sananya-san,

Thank you for your comment.

I can understand.

 

Tetsuo

0 Likes