cancel
Showing results for 
Search instead for 
Did you mean: 

USB Hosts Hubs Transceivers

AnPe_854906
New Contributor

Hi we use the CY7C65642-48AXC high speed USB hub on our product.  We have a strange requirement that requires the upstream port on this device to run at full speed only.  Can this be configured by pin strapping / or otherwise without the upstream device having to be full speed only itself.  i.e. if the PC upstream is high speed capable but the the hub is connected and only responds to full speed (i.e. it does now do the high speed chirp!)?

   

This is to allow us to easily fix a very specific problem we experience with high speed we see with a particular super speed monitor hub (very specific to our product so will not go into irrelevant detail here).

   

Thanks

   

Andrew

0 Likes
Reply
3 Replies
Anonymous
Not applicable

There is a resistor called Rref. Please change it from 650 Ohm to 500 Ohm and try. This would force it to work in full speed.

   

Regards,

   

- Madhu Sudhan

0 Likes
Reply
AnPe_854906
New Contributor

Madhu,

   

I have tested this and it does not seem to change anything and all high speed USB traffic is still directed through to the EHCI in the host machine.  Any other ideas.  I have worked around this issue by disabling the ECHI in the host but this means they have no high speed support now so it quite a compromise but means it works for now.

   

 

   

Andrew

0 Likes
Reply
prc_1505996
Contributor

Hi,

   

 Please remove Rref and try.

0 Likes
Reply