cancel
Showing results for 
Search instead for 
Did you mean: 

USB Hosts Hubs Transceivers

lahu_4391571
New Contributor

Hello,

We use the CY7C65632-28 as a 3-port hub and we follow pretty close to the reference design.  Issue is taht the chip keeps dying and I cannot figure what we did wrong to kill the chip.

Attached schematic, hope someone would show what we did wrong

Thanks

0 Likes
Reply
1 Solution
Sananya_14
Moderator
Moderator

Hello Lam,

I will check and update about the reflow temperature profile. Could you please probe the VCC and USB_nENP1 lines with no downstream devices connected? This will confirm if the power system is stable and it may be device dependent issue.

Best Regards,

Sananya

View solution in original post

0 Likes
Reply
5 Replies
Sananya_14
Moderator
Moderator

Hello,

-Could you kindly explain what happens when you say chip is dying? Could you kindly check the USB_nENP1 and RST#_USB signals at that instance?

-Please check if the crystal is working in that case. You can also check the KBA if it is similar to your issue.

Best Regards,

Sananya

0 Likes
Reply
lahu_4391571
New Contributor

Hello Sananya,

Look like all vital pins are functional, 12 MHz clock, internal 3.3V are good, reset pin OK and I can see it toggles high-low-high on stimulus but USB_nENP1 stuck to high therefore no power to the client ports

Thanks

Lam

0 Likes
Reply
Sananya_14
Moderator
Moderator

Hello Lam,

Please check if any of the overcurrent pins OVRP1, OVRP2 or OVRP3 are asserted? Does the issue occur if you attach any other devices on the downstream ports?

Best Regards,

Sananya

0 Likes
Reply
lahu_4391571
New Contributor

Hello Sananya,

There is no over-current happening.  Even though it is a 4-port hub, we have only one downstream device permanently connected (ST Micro MCU).  If we replace the part, the USB hub functionality would be OK for a while then the chip dies again.  Do you know where I can get a reflow temperature profile for that chip?

Thanks

Lam

0 Likes
Reply
Sananya_14
Moderator
Moderator

Hello Lam,

I will check and update about the reflow temperature profile. Could you please probe the VCC and USB_nENP1 lines with no downstream devices connected? This will confirm if the power system is stable and it may be device dependent issue.

Best Regards,

Sananya

View solution in original post

0 Likes
Reply