cancel
Showing results for 
Search instead for 
Did you mean: 

USB EZ-PD Type-C

JuLi_4162311
New Contributor

Without any modification, the CYPD4225-40LQXI_notebook project does not compile and generates a linker script error:

Build error: error: lto-wrapper failed: cm0gcc.ld

I am using PSoC creator 4.2

There were a few other errors but I was able to clear them up by updating the components.

I found this KBA but I am not sure it applies to the specific CCG4 chip on the evaluation board:

Build CCG4M Project Using CCG4 Project in SDK 3.0.1 and Later Versions – KBA219845

If it does, please let me know.

Thanks!

Julio

0 Likes
1 Solution
YiZ_31
Moderator
Moderator

Hi Julio,

CCGx SDK is suitable for PSOC Creator 3.3. PSOC Creator 4.0 and later version will have linker issues when compiling these projects.

You can download PSOC Creator 3.3 here.

Regards,
Eddie

View solution in original post

0 Likes
2 Replies
YiZ_31
Moderator
Moderator

Hi Julio,

CCGx SDK is suitable for PSOC Creator 3.3. PSOC Creator 4.0 and later version will have linker issues when compiling these projects.

You can download PSOC Creator 3.3 here.

Regards,
Eddie

View solution in original post

0 Likes
JuLi_4162311
New Contributor

Thank you!

On Mon, Apr 15, 2019 at 10:13 PM EddieZ_31 <community-manager@cypress.com>

0 Likes