cancel
Showing results for 
Search instead for 
Did you mean: 

USB EZ-PD Type-C

Contributor II

Attempting to run examples for CCG4 components results in linker failures.

Advice on community has been to use PSoC Creator 3.x.

When will a fix for these issues be available?

Reference:

Greg

0 Likes
Reply
1 Solution
Moderator
Moderator

Hi Greg,

I would strongly recommend you use PSoC Creator 3.3 for SDK 3.0.2 firmware build.

1. There is no work around if you want to use code example from SDK3.0.2. The lto-wrapper error is because of pre-lib of CCGx firmware. What's pre-lib files of CCGx firmware, you could refer below define.

pastedImage_0.png

2. If you want insist to use PSoC Creator 4.3, below way may be work (Please kindly notice that this is not full validated.)

a. Using code example of CCGx Host SDK.

b. Change the project from PD3.0 to PD2.0 as per SDK user guide. Refer below information:

pastedImage_1.png

Best Regards,

Lisa

View solution in original post

3 Replies
Moderator
Moderator

Hi Greg,

This is not issue, it is user error.

If you are new created project based on CCGx power SDK (https://www.cypress.com/documentation/software-and-drivers/ez-pd-ccgx-power-software-development-kit )  or CCGx Host SDK (https://www.cypress.com/documentation/software-and-drivers/ez-pd-host-software-development-kit ), you could use PSoC Creator 4.2 to develop it.

If you are new created project based on CCGx SDK v302 (https://www.cypress.com/documentation/software-and-drivers/ez-pd-sdk-v302-ccg2-all-applications-ccg3... ), you have to use PSoC Creator 3.3 or 4.0.

The reason is the PSoC Creator have changed gcc compiler version from 4.0 to 4.1, 4.2. And CCGx library is pre-build based on the gcc compiler version or MDK compiler. If the build IDE have difference version, the error will be occurred.

Since CCGx SDK v302 is supporting the project based on CCG2, CCG3 (part of part number, CYPD3120, CYPD3123) , and CCG4 (part of part number, CYPD4125, CYPD4225) . Those part numbers CCG2, CYPD4125, CYPD4225 is for PD2.0 device, it will not be update the SDK any more. The part number of CCG3 firmware, the update firmware is ready, you could get it from local FAE or contact Cypress support Team.

Best Regards,

Lisa

0 Likes
Reply
Contributor II

Lisa,

Is there a work-around for the lto-wrapper error?

Am I doing something wrong?

...in my process? (see attached)

...in my setup?

          I'm seeing three of each of several examples.

          I appear to have SDK 3.0.2 loaded. (again, see attached).

          Do I need to clear previous SDKs before loading new ones?

Greg

0 Likes
Reply
Moderator
Moderator

Hi Greg,

I would strongly recommend you use PSoC Creator 3.3 for SDK 3.0.2 firmware build.

1. There is no work around if you want to use code example from SDK3.0.2. The lto-wrapper error is because of pre-lib of CCGx firmware. What's pre-lib files of CCGx firmware, you could refer below define.

pastedImage_0.png

2. If you want insist to use PSoC Creator 4.3, below way may be work (Please kindly notice that this is not full validated.)

a. Using code example of CCGx Host SDK.

b. Change the project from PD3.0 to PD2.0 as per SDK user guide. Refer below information:

pastedImage_1.png

Best Regards,

Lisa

View solution in original post