cancel
Showing results for 
Search instead for 
Did you mean: 

USB EZ-PD Type-C

TaAi_1278401
New Contributor II

Hi

I want to replace CYPD3120 to CYPD3125 at dp dongle project.

But, I have the following problem at Notice List.

"The selected target type: Application Code and Data 2 is not valid for the current project configuration." and

"CyDsFit aborted due to errors, please address all errors and rerun CyDsFit."

Am I making a mistake?

Changes that I have made is the following

1 . I have opened CYPD3120 dp dongle project form EZPD CCGX SDK 3.02.

2. device have replaced CYPD3120 to CYPD3125 by Select Device window.

3. changed Bootloadable compornet for CYPD3125 at TopDesing.cysch. Bootloadable compornet have moved from same SDK CYPD3125 notebook project. 

Use PSoC Creator 3.3 CP3.

0 Likes
1 Solution
Sananya_14
Moderator
Moderator

Hi Taai,

Please update the bootloadable component with the CYPD3125-40LQXI_i2c_boot_1_0_3_461_0_0_0_nb. hex and CYPD3125-40LQXI_i2c_boot_1_0_3_461_0_0_0_nb.elf files from the Bootloader folder in CYPD3125 notebook project.

Best Regards,
Sananya

View solution in original post

4 Replies
Sananya_14
Moderator
Moderator

Hi,

Please use PSoC Creator 3.3 DP1 (build 9674), which can be installed from PSoC Creator Software Archive and try the same steps. Please also let us know if you have made any other changes to the DP dongle project other than changing the part number as you mentioned above.

Best Regards,

Sananya

0 Likes
TaAi_1278401
New Contributor II

Hi, Sananya.

thank you for reply.

I Tried your advice. but i can't solved same error. 

I have added the following changes

chaned device  at Project 'noboot'.and Updated bootloadable compornet to ver1.5.

is the configure 'bootloadable' correct? 

-------------------------------------------------------------

application version 0x4359

application ID 0xFFFF

application custom ID 0x00000002

placement address 0x00001800

 bootloader HEX file:  ...\Bootloader\CYPD3125-40LQXI_dummy_boot.hex

bootloader ELF file: ...\Bootloader\CYPD3125-40LQXI_dummy_boot.elf

--------------------------------------------------

Best Regards, taai

0 Likes
Sananya_14
Moderator
Moderator

Hi Taai,

Please update the bootloadable component with the CYPD3125-40LQXI_i2c_boot_1_0_3_461_0_0_0_nb. hex and CYPD3125-40LQXI_i2c_boot_1_0_3_461_0_0_0_nb.elf files from the Bootloader folder in CYPD3125 notebook project.

Best Regards,
Sananya

View solution in original post

TaAi_1278401
New Contributor II

Hi Sananya

Thanks for reply.

My problem was solved.

Best regards, taai

0 Likes