cancel
Showing results for 
Search instead for 
Did you mean: 

USB EZ-PD Type-C

Anonymous
Not applicable

Hello,

I tried to compile SDK sample code of CYPD3125-40LQXI_notebook with Creator 4.1.

CCGx FW UserGuide described, "This version of the SDK requires PSoC Creator 3.3 DP1 (build 9674) or higher".

At first, I update all of the components used in the project to latest version.

Next, I set up the option for ARM MDK Generic.

Finally, build it.

Also, I could build the project with Creator 3.3.

Creator shows many errors below. So please let me know how I can resolve them.

1) Build error: error: lto-wrapper failed

2) Build error: The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.

3) The instance 'HPI_IF', of component SCB_P4_v3_10, contains an error. Unable to locate and customize component 'SCB_P4_v3_10' used in schematic

4) The instance 'MUX_CTRL', of component SCB_P4_v3_10, contains an error. Unable to locate and customize component 'SCB_P4_v3_10' used in schematic

5) The fitter aborted due to errors, please address all errors and rebuild.

Best regards,

0 Likes
1 Solution
ShifangZ_26
Moderator
Moderator

Hi Takeshi,

You are correct that the SDK3.0.2 has to be used with Creator 3.3 DP1. There will not compiling error will be pop-up.  This error show up for Build error: error: lto-wrapper failed is because the gcc compiler is changed from 3.3 to 4.1, and CCGx 3.0.2 is released before Creator 4.1. I am checking if there is anyway to link the compiler of Creator 3.3 DP1 to Creator 4.1 to help out this issue.

For other errors, you could update all of components to latest one will fix it.

Best Regards,

Lisa

View solution in original post

0 Likes
4 Replies
Roy_Liu
Moderator
Moderator

Please try with the PSoC Creator software downloadable from EZ-PD Software Development Kit | Cypress Semiconductor

Roy Liu
0 Likes
ShifangZ_26
Moderator
Moderator

Hi Takeshi,

You are correct that the SDK3.0.2 has to be used with Creator 3.3 DP1. There will not compiling error will be pop-up.  This error show up for Build error: error: lto-wrapper failed is because the gcc compiler is changed from 3.3 to 4.1, and CCGx 3.0.2 is released before Creator 4.1. I am checking if there is anyway to link the compiler of Creator 3.3 DP1 to Creator 4.1 to help out this issue.

For other errors, you could update all of components to latest one will fix it.

Best Regards,

Lisa

View solution in original post

0 Likes
dapec_2892156
New Contributor

Lisa,

Is this still the case in PSoC Creator 4.2?

I'm trying to compile the CCG4M project for CYPD4155-96BZXI, I'm getting a similar set of errors:

     lto1.exe: fatal error: bytecode stream generated with LTO version 3.0 instead of the expected 4.1

     compilation terminated.

     lto-wrapper.exe: fatal error: arm-none-eabi-gcc.exe returned 1 exit status

     compilation terminated.

     ERROR: error: lto-wrapper failed

     collect2.exe: error: ld returned 1 exit status

     The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.

Compiling works in Creator 3.3

0 Likes
ShifangZ_26
Moderator
Moderator

Hi David,

I guess you are referring Build CCG4M Project Using CCG4 Project in SDK 3.0.1 and Later Versions – KBA219845 .

CCG4M project for CYPD4155-96BZXI is based on CYPD4226-40LQXIT/CYPD4126-40LQXIT. If you need use PSoC Creator 4.2, feel free to new customize it as per KBA. Otherwise, you have to link old gcc compiler to PSoC Creator 4.2 to support this project in PSoC Creator 4.2.

Best Regards,

Lisa

0 Likes