cancel
Showing results for 
Search instead for 
Did you mean: 

USB EZ-PD Type-C

mafic_3989141
New Contributor

Hi have a problem with a CCG3PA development kit, I have uploaded the firmware for Power Bank, but when try to recharge the battery nothing append.

I use a single cell battery 3000mAh 1C charge 2C discharge.

I moved the 0R resistance to the position for a single cell.

The device charging through type C works, while if I connect a QC3 USB power supply to the development board nothing happens.

When I connect the developer board to the PC through the micro USB cable and moving the bridges to activate the programming as per manual, often it does not detect the board but only NOTEBOOK, with an error on VDM id.

I hope you can help me

Massimo

0 Likes
1 Solution
YiZ_31
Moderator
Moderator

Hi Massimo,

I may have found something! Have you set the Jumper J2 J3 and J4 to 2&3 after download PB firmware ? As is described in the CCG3PA Evaluation Kit user guide:"For Jumper Header J2 J3 J4: Short 1 and 2 if the existing FW loaded on the EVK is PA firmware. Short 2 and 3 if PB firmware is loaded".

Maybe your firmware is downloaded correctly, what you need to do is just changing the  jumper header setting.

Regards,

Eddie

View solution in original post

0 Likes
13 Replies
YiZ_31
Moderator
Moderator

Hi Massimo,

May I know what firmware you use (like CYPD3171-24LQXQ_pb ?) Can you update firmware through SWD interface to program now?

Regards,

Eddie

0 Likes
mafic_3989141
New Contributor

The FW used is CYPD3171-24LQXQ_pb_3_1_2_1511_0_0_0_pb. What mean for SWD interface? I program this connecting the micro USB cable to the PC and to the card when I do not receive the error GET_SILICON_ID VDM failed, I program it in this way and everything works except for the recharge via an external adapter connected to either usb type c or usb type a. The error GET_SILICON_ID VDM failed appears to me several times and I can not see the ccg3pa until I disconnect the cable and or reconnect

0 Likes
YiZ_31
Moderator
Moderator

Hi Massimo,

For the problem of cannot recharging the battery, we need you to supply the message of CC line captured by sniffer like CY4500, and monitor the voltage of VBUS and C_CTRL.

For the problem of error on VDM id, we need you to enable the verbose device log in the option of EZ-PD configuration utility and save the complete log.

Regards,

Eddie

0 Likes
mafic_3989141
New Contributor

Thank you for fast response.

We don't use the cc lines because for recharge the battery we have connected a cable USB Type C to USB 3.0 male at the adapter QC3.

This is the log:

Searching for HID Firmware Update Device

0 HID devices found.

Registered device 0 (0 0) with handle b85e8e8

1 USB-Serial Bridge devices found.

Communication interface initialized.

Error: USB device (0,0) de-initialization failed

Searching for HID Firmware Update Device

0 HID devices found.

Registered device 0 (0 0) with handle b85e8e8

1 USB-Serial Bridge devices found.

Communication interface initialized.

Application Type is 6E62

Setting EVENT_MASK to enable VDM events.

RESET_COMPLETE event detected.

PD contract established.

Discover Id Response: Msg Header=0xff008041 ID Header=0x920004b4 CertStat VDO=00000000 Product VDO=f6600000 Product Type VDO=00000000

Silicon ID of device: 0x2003

USB-Serial [Single Channel] (0)$*NOTEBOOK:1&PORT(0)-DRP:1!#EMCA-SOP':0!#EMCA-SOP'':0!#UFP-Peripheral:1$

Device Discovery completed.

UPDATE:

I have more and more problems, when try to connect the development kit to pc, when i try to upgrade firmare sometimes we have problem with upgrade the firmware. Now i have a power adapter for a mack book pro last gen with usb type c 3.1 and then now recharge the device. How can i recharge the batteries with an USB 3.0 with DRP?

Anyway we have same problem:

Starting Device Discovery.

Searching for HID Firmware Update Device

0 HID devices found.

Registered device 0 (1 0) with handle 10faba88

1 USB-Serial Bridge devices found.

Communication interface initialized.

Application Type is 6E62

Setting EVENT_MASK to enable VDM events.

RESET_COMPLETE event detected.

Could not establish PD contract.

USB-Serial [Single Channel] (0)$*NOTEBOOK:1&PORT(0)-DRP:1$

Device Discovery completed.

and sometimes this message:

Searching for HID Firmware Update Device

0 HID devices found.

Registered device 0 (1 0) with handle 10fabbf0

1 USB-Serial Bridge devices found.

Communication interface initialized.

Application Type is 6E62

Setting EVENT_MASK to enable VDM events.

RESET_COMPLETE event detected.

PD contract established.

Discover Id Response: Msg Header=0xff008041 ID Header=0x2c0004b4 CertStat VDO=00000000 Product VDO=f6650000 Product Type VDO=0x000008

Error: GET_SILICON_ID VDM failed

Retrying, ignore the above error message

USB-Serial [Single Channel] (0)$*NOTEBOOK:1&PORT(0)-DRP:1!#EMCA-SOP':0!#EMCA-SOP'':0!#UFP-AMA:1$

Device Discovery completed.

when try to program, with all correct mode jumpers

Regards, Massimo

0 Likes
YiZ_31
Moderator
Moderator

Hi Massimo,

I got a board with similar problem as yours yesterday. This could caused by the unstable power supply.When there are more and more unpredictable errors, the power circuit could have been damaged. If I change to another board with exactly the same operation, everything works out fine.

Regards,

Eddie.

0 Likes
mafic_3989141
New Contributor

Hi Eddie, but i have bought the card last week and this problem has always been there. now how can I do? Regarding the talk of battery charging with a USB 3.0 type a power supply that does not use the Cc lines, how can I activate the battery charging?

0 Likes
YiZ_31
Moderator
Moderator

Hi Massimo,

As you have described, you firmware is not upgraded successfully. The correct downloading process should not show any error message, and the device will not disappear after downloading. And since you are using the firmware included in the SDK, the problem of firmware should be ruled out. For now, could you measure the voltage on TP2 TP4 of main board ?

Regards,

Eddie

0 Likes
mafic_3989141
New Contributor

Dear Eddie

In fact, sometimes the firmware loads it, because the firmware message loaded correctly appears, but only once in ten, but the only time it has loaded it, however, the device does not charge the battery connected with a USB 3.0 power supply connected to the USB type C, but only using a USB Type C charger such as the latest version of the macbook pro.

How can I activate the battery recharge without CC lines?

In any case, the voltages on the TP2 = 5.07V and TP4 = 1.76V.

Greatings

Massimo

0 Likes
YiZ_31
Moderator
Moderator

Hi Massimo,

The PD protocol is based on the massage exchange via CC lines, that's the reason why Type-C port need CC line. The CCG3PA will provide power only when the correct message is exchanged between source and sink. So you cannot activate battery charge without CC lines.

Regards,

Eddie

0 Likes
mafic_3989141
New Contributor

Another solution for make this application?

We need PD for recharge devices but not for recharge battery, and its necessary the dual role port on Type C, because we need to make a compact powerbank with only a USB Type C port.

Greetings

Massimo

0 Likes
mafic_3989141
New Contributor

Anyone can help me?

0 Likes
YiZ_31
Moderator
Moderator

Hi Massimo,

I may have found something! Have you set the Jumper J2 J3 and J4 to 2&3 after download PB firmware ? As is described in the CCG3PA Evaluation Kit user guide:"For Jumper Header J2 J3 J4: Short 1 and 2 if the existing FW loaded on the EVK is PA firmware. Short 2 and 3 if PB firmware is loaded".

Maybe your firmware is downloaded correctly, what you need to do is just changing the  jumper header setting.

Regards,

Eddie

View solution in original post

0 Likes
mafic_3989141
New Contributor

Thank you! now works

0 Likes