cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

New Contributor II

I'm using Psoc Creator 3.3_SP2. It takes almost 15 minutes to enter debug mode every time.  Every project ! Every time!

Psoc Creator is installed on C disk and other modules in the software don't have this phenomenon.

I can' understand why....and this problem seriously affects my work efficiency. Could you help me, please?

Thank you very much.

0 Likes
Reply
1 Solution
Esteemed Contributor II

Creator 3.3 is a bit outdated. I would suggest to try Creator 4.2 (actual version). Update for some components will be required, I2C APIs have changed.

Check if you have network connections which (when invalid) can increase access times dramatically.

Check the PATH environment for invalid entries.

Bob

View solution in original post

2 Replies
Esteemed Contributor II

Creator 3.3 is a bit outdated. I would suggest to try Creator 4.2 (actual version). Update for some components will be required, I2C APIs have changed.

Check if you have network connections which (when invalid) can increase access times dramatically.

Check the PATH environment for invalid entries.

Bob

View solution in original post

New Contributor II

Sorry for my replay lately and thanks a lot for your answer.  This problem was solved by changing network connections which can increase access times.  In menu of Psoc Creator 3.3, there is a setting option should be changed.

(Tools->Options->Environment->External file extensions:)

Erase all content in external file extensions, then Psoc creator can go into debug mode in 1~2 minutes!