Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

New Contributor II

I'm trying to use the USBUART with Win 7 - 64 bit.


 I've spent allot of time trolling through this forum to find an answer to this but so far no luck.
PSOC creator used to generate an .inf  file after compiling the project but no more.
The datasheet doesn't really tell you where to find the driver so somehow I figured out that it can be found in the Cypress Suite USB 3.4.7 folders. The docs over there tell me that the driver for Vista 64 is Win 7 64 compatible. I cruised over to the "Drivers" folder and saw that there are drivers for "w2k", "wxp" and something called "wlh" but no "Vista" or "Win 7" folders.
I figured that the "wlh" folder is my best option and so I dragged the files over to my project folder, plugged in the correct VID/PID info and manually installed the driver via Device Manager.
After having to reboot / F8 to tell Wiindows to ignore ditial signatures I get the dreaded "Code 10".


The only thing I changed in the USBUART config was the VID/PID and told it to be self powered.
The voltage is correct at 5V and the code is there to turn on global interrupts, start the USBUART and enumerate.


I used to have this all wroking with the old USBUART when the only component available was the USBFS.

Any suggestions?


5 Replies
Honored Contributor II

AFAIK you really need only the *.inf file - the driver itself is part of Windows. See and .

New Contributor II

 Tried pointing Windows to both the PSOC3 and PSOC5 folders in my project directory and get the same result (attached).
In both cases I was selecting the "USBUART_1_cdc" file.

Expert II

I succeeded by letting windows download the driver from its update site.


Sometimes I needed to de-install a driver with USBDeview from, then after plugging in anew the required drivers got downloaded.





New Contributor II

I found this:
So I downloaded these drivers: and ran the setup application.


I used USBDeview to uninstall the old drivers and then plugged the device back in.
Windows found the USB Serial driver and then started to try and install the CDC Driver but couldn't find one.
Then my PC completely locks up. I have to perform a hard reboot.
Difficult to troubleshoot when you're PC locks up.


I took pics of my screen after my PC froze. This happens every time.


New Contributor II

 Another pic of my frozen computer screem