cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

Anonymous
Not applicable

Hello community, I am a PSoC beginner and want to start with the PSoc Creator 4.0 software. So I installed PSoC Creator 4.0 Update 1 (typical) on the 4th PC. OS: Win 10 home. (German) Processor: I5-7200 RAM: 4 GB SSD The software I have registered, checked "i'd like to help ..." and Level 3 . Then I created a new project. Under Target Device, I have selected PSoC 4200 because I want to use the CY8CKIT-049-42xx. After that, I chose an empty schematic and waited until the project was created. Then I drag 'n drop an AND gate on the emty schematic. After this I only moved the gate and the software freezes and reported " no response" in the title bar. After 15 seconds the software was operable again. I come to the conclusion that the software does not work properly on four PCs now. It is a pity because I would have liked to know the functionalities of the PSoCs. After 3 weeks trying and serching for solutions it is (on four different PCs) not possible to work with PSoC Creator 4.0 ?!? Someone has an idea what could be the cause? For me it is not comprehensible! Many thanks in advance best regards Andreas

0 Likes
1 Solution
AnkitaS_51
Employee


Can you try the steps as shown in the attached document and see if it makes any difference.

View solution in original post

0 Likes
8 Replies
JoMe_264151
Expert II

Welcome in the forum, Andreas.

   

Are you using network drives on your PCs?

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Excuse me,Do you have a program package for CYBLE 212006-01?

HI,Bob Recently I was learning CY8CKIT-042-BLE debugging,The Bluetooth module is cyble 212006-01,However, there is no official website on the cypress program development package,I found out that you've been working on this for a long time,So I would like to ask if you have this program development kit   

0 Likes
Anonymous
Not applicable
        Hi Bob, I'm using now a Win7 Home PC with i7-2670 CPU, 8GB RAM. The PC is connected to local network (no DNS server). I use the network mainly for the internet and for access to a home automation system with a browser. Pre-installed manufacturer drivers are used for the network card. So no special drivers. Even if I disconnect the LAN cable and deactivate the virus scanner G-Data and the firewall, then the software freezes (after every small action on the schematic) for 10 or more seconds. The CPU load is only 10-15%. It's only the PSoC Creator Software that does not work properly?!? It is inexplicable because it does not work for me on 4 different PCs from the first day. Best regards Andreas   
0 Likes
JoMe_264151
Expert II

I was not asking for a network connection but for using a network drive share. With every move of a component several files get accessed which usually is no problem. When any of the files reside on a network share which cannot be accessed/searched there is a timeout for that try.

   

When this situation is not the case I would suggest to contact Cypress directly (might take some time because of Eastern holidays): At top of this page click on "Design Support -> Support -> Create a Support Case".

   

 

   

Bob

   

PS: Where in Germany are you located? I live near Bremen,

0 Likes
Anonymous
Not applicable
        Hi Bob, I misread, sorry. I do not use network drives. What I did not say before is that I previously communicate my problem at MyCase. Because no one could help me there, they have recommended this forum here. It is annoying because some days ago I have got the board and can not use it. I do not believe that my problem is unsolvable. By the way, I live near Cologne. Best regards and happy Easter Andreas   
0 Likes
JoMe_264151
Expert II

Too bad. I run Creator flawlessly on several different machines. Something must be special to your installations, as a common driver or something else. Did you already try running Creator with admin rights? Have you got any language specific characters (äöüß) in your path names or username?

   

Check actual version of  your dot net environment.

   

 

   

Bob

   

PS I lived 4 years in Köln Flittard (Bayer Leverkusen)

0 Likes
AnkitaS_51
Employee


Can you try the steps as shown in the attached document and see if it makes any difference.

View solution in original post

0 Likes
Anonymous
Not applicable
        Hello @ Bob I uninstalled .net framework <= v4.6.1 and replaced by v4.6.2, unfortunately without success. @ANKS I have followed your instructions. After entering: % windir% \ Microsoft.NET \ Framework \ v4.0.30319 \ ngen.exe display psoc_creator I got the following result: Error: The specified assembly is not installed. So I run "cyoptimizesetup.exe INSTALL" And ... that was the solution !!! PSOC Creator 4.0 is finally running after several weeks of error searching !!! I thank you all very much for your great help. Hope in the future I will have only "normal" beginner problems 😉 Thanks a lot and best regards Andreas