cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

Anonymous
Not applicable

Hi 

   

 

   

I moved source files in my projects to folders to clean/make project more clear.

   

After this, few files are not being compiled, I am geting error:

   

 

   
arm-none-eabi-gcc.exe: error: .\CortexM0\ARM_GCC_493\Debug\sample_file.o: No such file or directory
   

 

   

It happens after Clean and built. When I compile those .c filest manualy from list (right mouse -> Compile_file) then .o files are generated.

   

 

   

But again, cleaning deletes them. 

   

 

   

What happened?

0 Likes
Reply
1 Solution
JoMe_264151
Expert II

You have to set the path to your source files in project settings, include directories.

   

 

   

Bob

View solution in original post

0 Likes
Reply
6 Replies
JoMe_264151
Expert II

You have to set the path to your source files in project settings, include directories.

   

 

   

Bob

View solution in original post

0 Likes
Reply
Anonymous
Not applicable

How? I cannot find this. I have folder path in include.

   

What is more, not all files get this error. Only few. 

   

 

   

SOLVED:

   

Changing project name helped, seems that there is some bug. 

0 Likes
Reply
Anonymous
Not applicable

Again, with different file.

0 Likes
Reply
JobinT_31
Employee

Hi,

   

Can you post the project here?

   

Thanks

   

JOBIN GT

0 Likes
Reply
Anonymous
Not applicable

Sorry, I can not. 

   

I found other fix, seems that when you move files on HDD and then remove and add them again in PSoC Creator not all file path entries in LUXWIN_CPRL.cyprj.(your name) file are updated. I fixed them by hand and now everything seems to be ok. 

Anonymous
Not applicable

Perfect, got the same problem. I just deleted the <project_name>.cyprj.<your_name>, it will be recreated when you build the project.

0 Likes
Reply