Strictly necessary cookies are on by default and cannot be turned off. Functional, Performance and Tracking/targeting/sharing cookies can be turned on below based on your preferences (this banner will remain available for you to accept cookies). You may change your cookie settings by deleting cookies from your browser. Then this banner will appear again. You can learn more details about cookies HERE.
Strictly necessary (always on)
Functional, Performance and Tracking/targeting/sharing (default off)
Is there a way to change a pin's function name at compile time?
I'm using PSoC creator 3.3 and a CY8C3866AXI-206.
I had a PCB with a digital input on P2 but the next release of the PCB requires that pin be moved to P2. Other than the pin move the source code remains the same. For example; let say the input is just a switch. In the source I name the pin as "SW1" and read its value with "SW1_read()" .. which, originally, read from P2. Is there a way to modify that assignment at compile time ?? Some how do something like...