cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

AnAm_4616266
New Contributor

Hi,

I'm using CY8CKIT-062-WiFi-BT and trying to flash it with an example project. When I plug in the USB LED 2 and 4 stays solid. In device manager the device comes as "KitProg3 USB_UART (COM6)".

When I try to program the device in PSoC Creator (Debug -> Pogram), I can't see any cypress device under the Kitprog3 programmer.

pastedImage_1.png

Can you please advise what I'm missing here?

Thanks.

0 Likes
1 Solution
Len_CONSULTRON
Honored Contributor II

AnAm,

It looks from your Select Debug Target window that it could not find the Device listed in the the project.

There are generally two reasons for that.

  • PSoC Creator doesn't have a configuration for that device.  If so, make sure you are using PsoC Creator 4.2 or later.  This device was available only on later Creator releases.
  • The project target device does not match that of the Kit you've plugged in to your PC. 
    When you use an example project, the project may have been originally targeted for a different device.
    The one used in the CYC8KIT-062-WiFi-BT is CY8C6247BZI-D54.  If the device doesn't match, select the "Device Selector..."  menu item and chose CY8C6247BZI-D54.

Len

Len
"Engineering is an Art. The Art of Compromise."

View solution in original post

0 Likes
3 Replies
MotooTanaka
Esteemed Contributor

Hi,

I tested with My CY8CKIT-062-WiFi-BT,

but naturally I could not reproduce the problem.

But I could think of a couple of possible reasons (there could be many more though)

(1) The Device Data is not installed

(2) The project's target is a different device

For (1), we could download and install PSoC Programmer from the URL below.

Please select the newest one, as of today it is PSoC Programmer 3.28.7.exe

https://www.cypress.com/documentation/software-and-drivers/psoc-programmer-archive

For (2) in my PSoC Creator the device was CY8C6247BZI-D54

I just created a simple Green LED blinker project and attached.

FYI, I'm using PSoC Creator version 4.3

moto

0 Likes
Len_CONSULTRON
Honored Contributor II

AnAm,

It looks from your Select Debug Target window that it could not find the Device listed in the the project.

There are generally two reasons for that.

  • PSoC Creator doesn't have a configuration for that device.  If so, make sure you are using PsoC Creator 4.2 or later.  This device was available only on later Creator releases.
  • The project target device does not match that of the Kit you've plugged in to your PC. 
    When you use an example project, the project may have been originally targeted for a different device.
    The one used in the CYC8KIT-062-WiFi-BT is CY8C6247BZI-D54.  If the device doesn't match, select the "Device Selector..."  menu item and chose CY8C6247BZI-D54.

Len

Len
"Engineering is an Art. The Art of Compromise."

View solution in original post

0 Likes
DheerajK_81
Moderator
Moderator

From the screenshot, I see that the voltage detected is 1.1V which is strange because I would expect it to be nearly 1.8V when VDD is set to 1.8-3.3V variable position. Can you please set VDD to 3.3V position (SW5) and see if it works?

Regards,

Dheeraj

0 Likes