cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

New Contributor

Hi,

   

I have a windows 10 machine. I would like to install two versions of PSoC Creator on the same mahine. PSoC Creotor 3.3 SP1 and PSoC Cretor 3.3 CP3.

   

Let me know if this is possible or not?

   

Best Regards

0 Likes
Reply
1 Solution
Esteemed Contributor II

Afaik this is not possible. The CP3 stands for Component Package 3 and mainly updates your components to a newer version. For existing projects you may keep the original components without updating them.

   

The SP1 is Service Package and shows that the IDE has got new or corrected features or a newer GCC version.

   

You may look into Creator Release Notes to see what actually did change.

   

 

   

Bob

View solution in original post

0 Likes
Reply
6 Replies
Esteemed Contributor II

Afaik this is not possible. The CP3 stands for Component Package 3 and mainly updates your components to a newer version. For existing projects you may keep the original components without updating them.

   

The SP1 is Service Package and shows that the IDE has got new or corrected features or a newer GCC version.

   

You may look into Creator Release Notes to see what actually did change.

   

 

   

Bob

View solution in original post

0 Likes
Reply
New Contributor

Hi,

   

Updating to the new version breaks some projects for me built with older version of PSoC Creator with the following message.

   

E1216: Routing of net Net_199 Failed. Source : :m0s8tcpwmcell_7.tr_compare_match, Sink : :m0s8tcpwmcell_3.stop 

   

-regards

0 Likes
Reply
Honored Contributor II

You can run two major version (e.g. 3.3 and 3.2) in parallel, but I'm not sure whether you can run 3.3 SP1 and 3.3 CP1 in parallel. But there should be no need to do that - the should be identical in terms of functionality (and even bugs), and the older versions of the component are still available.

0 Likes
Reply
Esteemed Contributor II

There are two scenarios possible: The older version has a bug or the newer one has got it. I would always assume the former case.

   

Is it possible that you post your complete project, so that we all can have a look at all of your settings. To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting file.

   

If not, I would suggest you to get in contact with Cypress directly: At top of this page select "Design support -> Create a Support Case" and attach your progect bundle. Cypress will keep your information confidentially and you will be helped by a Cypress engineer.

   


Bob

0 Likes
Reply
New Contributor

Hi,

   

Thanks for the quick replies. I will get in touch with Cypress immediately.

   

Regards.

0 Likes
Reply
Employee

Bob and hli are correct that you cannot install multiple copies of PSoC Creator 3.3. You can only install different products, such as 3.2 and 3.3. The SP1 and CP3 are just different versions of the same product. It is a bit confusing and we are moving to a simpler "Update #" nomenclature soon.

   

The routing issue is a concern though, especially since it is happening on the newer software. But there is not much we can do on this forum without seeing the project. Please do contact our support department - they are responsive and experienced guys who will help you.