cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

New Contributor II

Hi all,

I have already posted about this before but here we go again. I have recently uninstalled psoc creator 4.2 and tried to re install it. Whenever the installation reaches the PSoC Programmer stage and the Clock Programmer stage, it tells me that there is a newer version already installed.

I already searched the registry and could not find anything else about it. It still gives me the same error and I cannot find these programs that are apparently already installed.

P.S the weird part is, the latest version of the clock programmer I could ind is the 1.8, so it would not sense for there to be a newer version already installed right?

0 Likes
Reply
1 Solution
Moderator
Moderator

The clock programmer should be installed along with the installation of psoc programmer.

The psoc programmer packaged in psoc creator installation package is 3.27, not updated the latest version(3.28) yet. Therefore, it's possible throw the error when you install the psoc creator, if you have already installed the newer version - v3.28​​ psoc programmer separately.

Please uninstall all version psoc programmer before psoc creator installation. If you are sure there is no any version psoc programmer is installed, please try out by restarting your PC.

View solution in original post

0 Likes
Reply
3 Replies
Moderator
Moderator

The latest version PSoC Programmer / Clock Programmer should be 3.28 / 1.9.0.

Please make sure you have uninstalled all version of PSoC Programmer and Clock Programmer before starting the PSoC Creator installation.

For the PSoC Creator to be installed, please get it from webpage - http://www.cypress.com/products/psoc-creator-integrated-design-environment-ide

0 Likes
Reply
New Contributor II

Whenever I try to install it, it keeps installing version 1.8, how do I instruct it to install 1.9?

0 Likes
Reply
Moderator
Moderator

The clock programmer should be installed along with the installation of psoc programmer.

The psoc programmer packaged in psoc creator installation package is 3.27, not updated the latest version(3.28) yet. Therefore, it's possible throw the error when you install the psoc creator, if you have already installed the newer version - v3.28​​ psoc programmer separately.

Please uninstall all version psoc programmer before psoc creator installation. If you are sure there is no any version psoc programmer is installed, please try out by restarting your PC.

View solution in original post

0 Likes
Reply