cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

New Contributor II

(I looked for a thread for this problem - I did not see one.)

I am using a CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT PioneerKit.

I used the default CE220923_VDAC_Sawtooth demo and it worked fine, despite some "incompatible" errors.

PSoC Creator 4.3 (upgraded from 4.2)

PDLSetup3.0.9 (I think)

I then changed the pin from the original pin9_6 to pin9_0.

I got a message that both pins were used. I got the same output on both pins.

I then rebuilt again, and got the error messages below, and the build failed.

I then replaced the DAC with the same (default?) settings. Recompiled. Same fail.

Then downloaded and ran PDLSetup3.1.2.exe

Recompiled. Same fail.

The "Component Update" keeps saying everything is at the latest rev.

I am compiling with the CM4 core on the PSoC 6.

At this point I am stuck.

Thanks .... bandit

project_info.png

DAC_PDL_1.png

DAC_PDL_2.pngDAC_PDL_update.png

dac_settings.png

0 Likes
Reply
1 Solution
Esteemed Contributor

Hi,

I tried the same thing, and got same warnings.

So I thought that the PDL selection was wrong.

From menu: Project > Build settings > Peripheral Driver Library

001-default-pdl.JPG

The default of my PSoC Creator was 3.1.0

So I used "Custom" and changed it to 3.1.2, which is the newest PDL I have on my system right now.

002-custom-pdl-3.1.2.JPG

And I did "update components" and "clean and rebuild", the project was built OK.

Then I noticed the "(Tools > Options)" in the "Default" selection.

So I followed it, too. From menu Tools > Options

003-tools-option.JPG

My PDL v3 (PSoC 6 devices) location was 3.1.0

004-Options.JPG

So I changed it to 3.1.2

005-pdl-selected.JPG

006-pdl-now-3.1.2.JPG

Now, my Default PDL is 3.1.2

007-default-is-now-312.JPG

Then I followed what you did, I changed the pin from P9[6] to P9[0].

And I did "Clean and Rebuild"

Although now I get 2 warnings, the project could be built.

010-compiled-with-new-pin.JPG

011-Rebuild-Succeeded.JPG

moto

View solution in original post

2 Replies
Esteemed Contributor

Hi,

I tried the same thing, and got same warnings.

So I thought that the PDL selection was wrong.

From menu: Project > Build settings > Peripheral Driver Library

001-default-pdl.JPG

The default of my PSoC Creator was 3.1.0

So I used "Custom" and changed it to 3.1.2, which is the newest PDL I have on my system right now.

002-custom-pdl-3.1.2.JPG

And I did "update components" and "clean and rebuild", the project was built OK.

Then I noticed the "(Tools > Options)" in the "Default" selection.

So I followed it, too. From menu Tools > Options

003-tools-option.JPG

My PDL v3 (PSoC 6 devices) location was 3.1.0

004-Options.JPG

So I changed it to 3.1.2

005-pdl-selected.JPG

006-pdl-now-3.1.2.JPG

Now, my Default PDL is 3.1.2

007-default-is-now-312.JPG

Then I followed what you did, I changed the pin from P9[6] to P9[0].

And I did "Clean and Rebuild"

Although now I get 2 warnings, the project could be built.

010-compiled-with-new-pin.JPG

011-Rebuild-Succeeded.JPG

moto

View solution in original post

New Contributor II

Thanks! I will try this next week.

They don't make it easy...

Yours ... bandit