cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

zhenning_zhu
New Contributor II

Using BHP, download App1. Show:

12:33:39 AM - program Started

12:33:39 AM - The bootloader reported error 'The flash row is not valid for the selected array.'.

12:33:39 AM - program failed in 159 ms.

0 Likes
1 Solution
ShipingW_81
Moderator
Moderator

please try attached project, which is verified as valid on my side.

View solution in original post

6 Replies
ShipingW_81
Moderator
Moderator

Zhu Zhenning

Did you test on the 062-ble dvk board? which version of the board you are using?

Please note the board rev*11 or earlier can not support PDL3.1.0, and thus not support to verify CE213903.

0 Likes
zhenning_zhu
New Contributor II

062-ble dvk ver.jpg

0 Likes
MarkA_91
Employee

I'm guessing that you're using the PSoC Creator version of the code example, as opposed to the ModusToolbox 1.0 version? They're both available on www.cypress.com. As the developer of this code example, I retested both and they both worked fine for me.

In the PSoC Creator version, the typical reason for the error that you're seeing is failure to edit the App1 linker script files from their defaults. This is step 2 on page 2 of the code example document. Please confirm that this has been done.

zhenning_zhu
New Contributor II

Would you please share your retested project to me?

0 Likes
ShipingW_81
Moderator
Moderator

please try attached project, which is verified as valid on my side.

View solution in original post

zhenning_zhu
New Contributor II

OK!

I should download App1 just after release SW2.

Thanks WansS_81 and MarkA_91 !

0 Likes
Top labels