cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

Contributor II

I have seen the question at cannot program PSOC 6  and my situation seems almost identical but the linked-to thread does not provide the answer.

I have a custom board that has a CYBLE-416045-02 on it plus a 32.768KHz crystal (for the deep sleep timer) and not much else (bypass capacitors, a reset switch and 2 resistive 2:1 voltage dividers to a couple of voltage sources I'm measuring - both have a max voltage of 4v so the voltage seen by the CPU is within range).

The device stopped working a few days ago and when I tried to re-program it I get:

There was an error while programming the device: PSoC Programmer reported error (100 - EraseAll API returned: Error code 0x76FFA400: Unknown SROM status code)

I've tried programming it with a KitProg2 (with the KitProg3 firmware) that was snapped off a CY8CPROTO-063-BLE and is the programmer used to originally program my board, and a KitProg4. I'm using the PSoC Creator V4.3 in Windows 10 64-bit (in a Parallels VM in an iMac running High Sierra 10.13.6) - this is the same environment I used to program the board in the first place.

Can someone please explain what the error code actually means?

Better still, how can it be fixed (step by step instructions please)?

Thanks

Susan

0 Likes
Reply
2 Replies
Contributor II

I have received an email from Ganesh at Cypress Tech Support regarding this question. He says:

The error you are seeing generally comes when the chip is not functional.

This is followed by a request for the schematic and the project.

(I'm responding here as I believe that this exchange may be of interest to others who end up with the problem.)

I have used another board of the same design and software and it is working well. However time will tell if there is something 'strange' that the code is doing to the chip - if the 2nd board fails after a few months as well then this could well be the case.

However it does suggest to me that there is nothing specifically wrong with the PCB itself - it does not rule out poor construction of the failed board.

I will try to program something else into the MCU but I do suspect that the device itself has become faulty.

Also I would still like an answer to the question above: what does the error code actually mean. It does not seem to be a random number as I was able to find other questions that quote the same error code so it would be useful to know more than "unknown SROM status code" - someone within Cypress MUST know what that code means.

Thanks to Ganesh for his response.

Susan

0 Likes
Reply
Moderator
Moderator

Hi,

There may be issue in the schematic or Layout and that is causing the chip to be non operative. Please check your schematic and Layout with our development kit's schematic or Layout. The links are given below:

https://www.cypress.com/documentation/development-kitsboards/cyble-416045-eval-ez-ble-arduino-evalua...

https://www.cypress.com/documentation/development-kitsboards/psoc-6-ble-prototyping-kit-cy8cproto-06...

Or if you can share your schematic as well as gerber files of the Layout we can review.

Thanks and regards

Ganesh

0 Likes
Reply
Top labels