cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

New Contributor

Hello:

I'm having issues with a PSOC 6 project (running freeRTOS) printing/receiving data through a USB port.

Originally, the project was developed using PDL 3.0.4. With that, I was able to use printf and sscanf to print data and receive data to a USB port with tera-term without any problems.

I then updated to PDL 3.1.0 and none of my printing or scanning code is working.

I've isolated the project to run one task that flashes an LED and prints characters out to the screen.

I am seeing the LED flashing (so I know my task is still running) but I don't see any data being printed.

I verified that the connected development board has properly enumerated. In windows Device Manager it is coming up as 'kitProg-2 USB-UART (Com 43)' (in the previous build with PDL 3.0.4, it enumerated the same way).

Any ideas as to why my printf is not working?

Thanks in advance.

0 Likes
Reply
1 Solution
Moderator
Moderator

In the Build Settings, when you changed the PDL, the packages selected might have got unchecked. Please ensure that Retarget I/O box is checked and SCB5 is added to the defines in the file "stdio_user.h".

#define IO_STDOUT_UART      SCB5

#define IO_STDIN_UART       SCB5

If you have this already setup and still doesn't work, please share your project so that we can inspect it further.

Regards,

Dheeraj

View solution in original post

2 Replies
Moderator
Moderator

In the Build Settings, when you changed the PDL, the packages selected might have got unchecked. Please ensure that Retarget I/O box is checked and SCB5 is added to the defines in the file "stdio_user.h".

#define IO_STDOUT_UART      SCB5

#define IO_STDIN_UART       SCB5

If you have this already setup and still doesn't work, please share your project so that we can inspect it further.

Regards,

Dheeraj

View solution in original post

New Contributor

Dheeraj:

Thanks, that was the issue!!

Everything is now working

0 Likes
Reply
Top labels